summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-10-14 13:52:09 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-23 11:08:44 +0100
commitd22add889f96d5d1813aebb327b8ada8d04fe4d2 (patch)
treebbf91e636c7e56d41f5d1098d50a1b89f1510050 /net-vpn
parentnet-vpn/eduvpn-common: new package, add 1.1.2 (diff)
downloadgentoo-d22add889f96d5d1813aebb327b8ada8d04fe4d2.tar.gz
gentoo-d22add889f96d5d1813aebb327b8ada8d04fe4d2.tar.bz2
gentoo-d22add889f96d5d1813aebb327b8ada8d04fe4d2.zip
net-vpn/eduvpn-client: new package, add 4.1.3
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Acked-by: Sam James <sam@gentoo.org> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/eduvpn-client/Manifest1
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild38
-rw-r--r--net-vpn/eduvpn-client/metadata.xml24
3 files changed, 63 insertions, 0 deletions
diff --git a/net-vpn/eduvpn-client/Manifest b/net-vpn/eduvpn-client/Manifest
new file mode 100644
index 000000000000..f75020c5bd16
--- /dev/null
+++ b/net-vpn/eduvpn-client/Manifest
@@ -0,0 +1 @@
+DIST eduvpn-client-4.1.3.gh.tar.gz 1163669 BLAKE2B 75184f21ecf24466e1496ced1295cb95a42e35f80d070a90dc9a2e2ed46272604703c0f56ebbc9a53b78f09a9ed685e64f578539502ef93b384d779d2a69af8c SHA512 2f180b238fc22dd19ae07a5e9e0518e51b302ecb1413a2d7f4fdb551f9cee5ef82ecf74498b63abb86745b8f9719a075b8d9758104cf124f88d65767944bc839
diff --git a/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild b/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild
new file mode 100644
index 000000000000..58124218aa8c
--- /dev/null
+++ b/net-vpn/eduvpn-client/eduvpn-client-4.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+# Test suite involves adding NetworkManager configuration entries,
+# disable for now.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=net-vpn/eduvpn-common-1.1.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
diff --git a/net-vpn/eduvpn-client/metadata.xml b/net-vpn/eduvpn-client/metadata.xml
new file mode 100644
index 000000000000..9eb729cd0bdd
--- /dev/null
+++ b/net-vpn/eduvpn-client/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Linux client for eduVPN
+
+ eduVPN is a frontend for either WireGuard or OpenVPN used widely at
+ european academic institutions. It features an easy to use VPN
+ configuration utility. Users just need to login occasionally with their
+ credentials issued by the institution to refresh their VPN
+ configuration.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">eduvpn/python-eduvpn-client</remote-id>
+ </upstream>
+</pkgmetadata>