summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2022-02-28 14:15:18 +0100
committerChristian Ruppert <idl0r@gentoo.org>2022-02-28 14:15:25 +0100
commit1e8eaccde8f0142c6530304e2437b6fa7d6203bc (patch)
tree46ec5d7b5c428e53749179f8fb9a2c8a4e122663 /net-wireless
parentnet-wireless/sdrplay: Bump + Several fixes (diff)
downloadgentoo-1e8eaccde8f0142c6530304e2437b6fa7d6203bc.tar.gz
gentoo-1e8eaccde8f0142c6530304e2437b6fa7d6203bc.tar.bz2
gentoo-1e8eaccde8f0142c6530304e2437b6fa7d6203bc.zip
net-wireless/soapysdrplay: Bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/soapysdrplay/Manifest1
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-20220120.ebuild30
-rw-r--r--net-wireless/soapysdrplay/soapysdrplay-9999.ebuild17
3 files changed, 40 insertions, 8 deletions
diff --git a/net-wireless/soapysdrplay/Manifest b/net-wireless/soapysdrplay/Manifest
index ee25bcdcc602..2b44b67cca04 100644
--- a/net-wireless/soapysdrplay/Manifest
+++ b/net-wireless/soapysdrplay/Manifest
@@ -1,2 +1,3 @@
DIST soapysdrplay-0.1.0.tar.gz 11736 BLAKE2B 746e01092d094cedb6b15b9c11ec0b828e18cd3c814e46cbe5cb9473cfd494d8342ab9618d8c5d945429b2b62178b02b81c2b000e20c53a7cb027d4b2a25c789 SHA512 28382b4ac79e27a0b84ed6edb4abeca99b90222ad2890041e1585cac21177518ca3fcea0a3e14f8502091d47e7b2a223913dd77c53b6c0360f0f3875328613da
DIST soapysdrplay-0.2.0.tar.gz 13570 BLAKE2B c77342b091a3510986e4388911dc2e45d7bc0e54dfef7ebe1fe774d564193bc773509d46238c0a3ea87458ab0c7ea2447a877f083a72a26f2ca5e592386b1ba1 SHA512 7ed6e34ee42416b4d2eec76b66cdc0e9b40835ab3299a2b3a906492cf342bbdef7c92dd3e9e63b12fdceb897ca4fb2bb574b23d4aee121cc32fbfcddbb7b060a
+DIST soapysdrplay-20220120.tar.gz 21089 BLAKE2B db8a8f7b20a57d637f69b45cab283419e46808ab95bfbcba96b155c696bb6673223347ef720c8556f4122a53659eb166edb15b48796b2e01ec3ee5bb10eafba1 SHA512 a0cd5e84da86ab9fc6ffae93e963a14091c0936bc93a0ab86d7c3cab15cf2e62e1382da9fff10b1f457d1fbf925dc3ea74683f0fa13e12394d994f9571e52334
diff --git a/net-wireless/soapysdrplay/soapysdrplay-20220120.ebuild b/net-wireless/soapysdrplay/soapysdrplay-20220120.ebuild
new file mode 100644
index 000000000000..446b5336ed79
--- /dev/null
+++ b/net-wireless/soapysdrplay/soapysdrplay-20220120.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugin for SDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay3"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay3.git"
+ EGIT_CLONE_TYPE="shallow"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT_HASH="b789d5985b900973c81c69aa04cb3c7ebe620a75"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay3-"${COMMIT_HASH}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr
+ >=net-wireless/sdrplay-3.07"
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
index 935b6c269996..446b5336ed79 100644
--- a/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
+++ b/net-wireless/soapysdrplay/soapysdrplay-9999.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Soapy SDR plugin for SDRPlay"
-HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
+HOMEPAGE="https://github.com/pothosware/SoapySDRPlay3"
if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay3.git"
EGIT_CLONE_TYPE="shallow"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
+ COMMIT_HASH="b789d5985b900973c81c69aa04cb3c7ebe620a75"
+ SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDRPlay3-"${COMMIT_HASH}"
fi
LICENSE="Boost-1.0"
@@ -25,5 +26,5 @@ IUSE=""
REQUIRED_USE=""
RDEPEND="net-wireless/soapysdr
- net-wireless/sdrplay"
+ >=net-wireless/sdrplay-3.07"
DEPEND="${RDEPEND}"