summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-28 11:07:36 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:32 +0300
commita01383e452525c74df3ab9892d2b423c7d9f0619 (patch)
tree6ace8f074b0254fa575c71c097e8740551119f04 /sci-astronomy/stellarium/files
parentdev-libs/qtcompress: new package (diff)
downloadgentoo-a01383e452525c74df3ab9892d2b423c7d9f0619.tar.gz
gentoo-a01383e452525c74df3ab9892d2b423c7d9f0619.tar.bz2
gentoo-a01383e452525c74df3ab9892d2b423c7d9f0619.zip
sci-astronomy/stellarium: version 0.20.3
Unbundle several libraries, install docs, update metadata.xml Due to new deps, even though they were bundled already, dropped some keywords (ppc, ppc64, and prefix ones). Will bring them back some of them later. Bug: https://bugs.gentoo.org/745234 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17639 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy/stellarium/files')
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch82
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch222
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch23
3 files changed, 327 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch
new file mode 100644
index 000000000000..ac3f84d5bb66
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch
@@ -0,0 +1,82 @@
+diff --git a/plugins/TelescopeControl/src/INDI/CMakeLists.txt b/plugins/TelescopeControl/src/INDI/CMakeLists.txt
+index a250e1bb0f..f14007c392 100644
+--- a/plugins/TelescopeControl/src/INDI/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/INDI/CMakeLists.txt
+@@ -25,7 +25,7 @@ add_library(TelescopeControl_INDI STATIC
+ target_link_libraries(TelescopeControl_INDI
+ Qt5::Core
+ Qt5::Network
+- indiclient
++ -lindiclient
+ TelescopeControl_common
+ ${CMAKE_THREAD_LIBS_INIT}
+ )
+diff --git a/plugins/TelescopeControl/src/INDI/INDIConnection.cpp b/plugins/TelescopeControl/src/INDI/INDIConnection.cpp
+index f401dc7049..d890d3aa14 100644
+--- a/plugins/TelescopeControl/src/INDI/INDIConnection.cpp
++++ b/plugins/TelescopeControl/src/INDI/INDIConnection.cpp
+@@ -25,9 +25,9 @@
+ #include <limits>
+ #include <cmath>
+
+-#include "indibase/baseclient.h"
+-#include "indibase/basedevice.h"
+-#include "indibase/inditelescope.h"
++#include "libindi/baseclient.h"
++#include "libindi/basedevice.h"
++#include "libindi/inditelescope.h"
+
+ const int INDIConnection::SLEW_STOP = INDI::Telescope::SLEW_GUIDE - 1;
+
+diff --git a/plugins/TelescopeControl/src/INDI/INDIConnection.hpp b/plugins/TelescopeControl/src/INDI/INDIConnection.hpp
+index 111ad2cdba..80ead01137 100644
+--- a/plugins/TelescopeControl/src/INDI/INDIConnection.hpp
++++ b/plugins/TelescopeControl/src/INDI/INDIConnection.hpp
+@@ -20,7 +20,7 @@
+ #define INDICONNECTION_HPP
+
+ #include <QObject>
+-#include "indibase/baseclient.h"
++#include "libindi/baseclient.h"
+
+ #include <mutex>
+ #include <QStringList>
+diff --git a/plugins/TelescopeControl/src/INDI/TelescopeClientINDI.cpp b/plugins/TelescopeControl/src/INDI/TelescopeClientINDI.cpp
+index 6bd7754ff5..633d4ae7b2 100644
+--- a/plugins/TelescopeControl/src/INDI/TelescopeClientINDI.cpp
++++ b/plugins/TelescopeControl/src/INDI/TelescopeClientINDI.cpp
+@@ -24,7 +24,7 @@
+
+ #include "StelCore.hpp"
+ #include "StelUtils.hpp"
+-#include "indibase/inditelescope.h"
++#include "libindi/inditelescope.h"
+ #include "INDIControlWidget.hpp"
+
+ TelescopeClientINDI::TelescopeClientINDI(const QString &name, const QString &params):
+diff --git a/plugins/TelescopeControl/src/INDI/test/testINDIConnection.cpp b/plugins/TelescopeControl/src/INDI/test/testINDIConnection.cpp
+index 6c1a281ec5..ca7b7e0c40 100644
+--- a/plugins/TelescopeControl/src/INDI/test/testINDIConnection.cpp
++++ b/plugins/TelescopeControl/src/INDI/test/testINDIConnection.cpp
+@@ -22,7 +22,7 @@
+ #include <cmath>
+
+ #include "INDIConnection.hpp"
+-#include "indibase/basedevice.h"
++#include "libindi/basedevice.h"
+
+ void TestINDIConnection::deafultCoordinates()
+ {
+diff --git a/src/external/CMakeLists.txt b/src/external/CMakeLists.txt
+index 6fcf7678da..a59d8c121c 100644
+--- a/src/external/CMakeLists.txt
++++ b/src/external/CMakeLists.txt
+@@ -176,7 +176,7 @@ target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
+ set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
+
+ ################################# INDI ################################
+-IF(USE_PLUGIN_TELESCOPECONTROL)
++IF(USE_PLUGIN_TELESCOPECONTROL AND 0)
+ set(INDI_SOVERSION "1")
+ set(CMAKE_INDI_VERSION_MAJOR 1)
+ set(CMAKE_INDI_VERSION_MINOR 6)
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch
new file mode 100644
index 000000000000..7a585b71894b
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch
@@ -0,0 +1,222 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1b72c2c8f6..9436bc66da 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -629,5 +629,6 @@ ELSE()
+ ENDIF()
+
++find_package(Qt5Compress REQUIRED)
+
+ ########### Set some global variables ###########
+ IF(UNIX AND NOT WIN32)
+diff --git a/plugins/Satellites/src/CMakeLists.txt b/plugins/Satellites/src/CMakeLists.txt
+index 8e3138adf2..b59049767d 100644
+--- a/plugins/Satellites/src/CMakeLists.txt
++++ b/plugins/Satellites/src/CMakeLists.txt
+@@ -55,7 +55,7 @@ IF(ENABLE_TESTING)
+ ENDIF(ENABLE_TESTING)
+
+ ADD_LIBRARY(Satellites-static STATIC ${Satellites_SRCS} ${Satellites_RES_CXX} ${SatellitesDialog_UIS_H})
+-TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets)
++TARGET_LINK_LIBRARIES(Satellites-static Qt5::Core Qt5::Network Qt5::Widgets Qt5::Compress)
+ # The library target "Satellites-static" has a default OUTPUT_NAME of "Satellites-static", so change it.
+ SET_TARGET_PROPERTIES(Satellites-static PROPERTIES OUTPUT_NAME "Satellites")
+ IF(MSVC)
+diff --git a/plugins/Satellites/src/Satellites.cpp b/plugins/Satellites/src/Satellites.cpp
+index 7432f4316d..f4f4453661 100644
+--- a/plugins/Satellites/src/Satellites.cpp
++++ b/plugins/Satellites/src/Satellites.cpp
+@@ -43,7 +43,7 @@
+ #include "StelUtils.hpp"
+ #include "StelActionMgr.hpp"
+
+-#include "external/qtcompress/qzipreader.h"
++#include "qzipreader.h"
+
+ #include <QNetworkAccessManager>
+ #include <QNetworkReply>
+@@ -1533,12 +1533,12 @@ void Satellites::saveDownloadedUpdate(QNetworkReply* reply)
+ QString archive = zip.fileName();
+ QByteArray data;
+
+- Stel::QZipReader reader(archive);
+- if (reader.status() != Stel::QZipReader::NoError)
++ QZipReader reader(archive);
++ if (reader.status() != QZipReader::NoError)
+ qWarning() << "[Satellites] Unable to open as a ZIP archive";
+ else
+ {
+- QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
++ QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
+ for (const auto& info : infoList)
+ {
+ // qWarning() << "[Satellites] Processing:" << info.filePath;
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index bdd214729f..81631ce8ec 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -465,7 +465,7 @@ IF(ENABLE_SPOUT AND SPOUT_LIBRARY_DLL)
+ CONFIGURE_FILE(${SPOUT_LIBRARY_DLL} ${CMAKE_CURRENT_BINARY_DIR} COPYONLY)
+ ENDIF()
+
+-SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} qtcompress_stel glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
++SET(STELMAIN_DEPS ${ZLIB_LIBRARIES} Qt5::Compress glues_stel qcustomplot_stel qxlsx_stel ${STELLARIUM_STATIC_PLUGINS_LIBRARIES} ${STELLARIUM_QT_LIBRARIES} ${SPOUT_LIBRARY})
+ IF(ENABLE_LIBGPS)
+ SET(STELMAIN_DEPS ${STELMAIN_DEPS} ${GPS_LIBRARY})
+ ENDIF()
+diff --git a/src/core/modules/LandscapeMgr.cpp b/src/core/modules/LandscapeMgr.cpp
+index 8da2070b26..9949252cee 100644
+--- a/src/core/modules/LandscapeMgr.cpp
++++ b/src/core/modules/LandscapeMgr.cpp
+@@ -1183,8 +1183,8 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
+ }
+ QDir destinationDir (parentDestinationDir.absoluteFilePath("landscapes"));
+
+- Stel::QZipReader reader(sourceFilePath);
+- if (reader.status() != Stel::QZipReader::NoError)
++ QZipReader reader(sourceFilePath);
++ if (reader.status() != QZipReader::NoError)
+ {
+ qWarning() << "LandscapeMgr: Unable to open as a ZIP archive:" << QDir::toNativeSeparators(sourceFilePath);
+ emit errorNotArchive();
+@@ -1193,7 +1193,7 @@ QString LandscapeMgr::installLandscapeFromArchive(QString sourceFilePath, const
+
+ //Detect top directory
+ QString topDir, iniPath;
+- QList<Stel::QZipReader::FileInfo> infoList = reader.fileInfoList();
++ QList<QZipReader::FileInfo> infoList = reader.fileInfoList();
+ for (const auto& info : infoList)
+ {
+ QFileInfo fileInfo(info.filePath);
+diff --git a/src/external/CMakeLists.txt b/src/external/CMakeLists.txt
+index 1e0e7e2b32..834aff89cb 100644
+--- a/src/external/CMakeLists.txt
++++ b/src/external/CMakeLists.txt
+@@ -70,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
+ set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ set(qtcompress_SRCS
+ qtcompress/qzip.cpp
+ qtcompress/qzipreader.h
+@@ -82,6 +83,7 @@ target_link_libraries(qtcompress_stel ${ZLIB_LIBRARIES} Qt5::Core)
+ #turn off automoc, not needed here
+ set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ set(qcustomplot_SRCS
+ qcustomplot/qcustomplot.cpp
+@@ -176,7 +176,7 @@
+ qxlsx/xlsxcelllocation.h
+ )
+ add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
+-target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
++target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
+ set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
+
+ ################################# INDI ################################
+diff -r 11536448457a xlsxzipreader.cpp
+--- a/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:41:22 2020 +0100
++++ b/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:42:03 2020 +0100
+@@ -28,13 +28,13 @@
+ namespace QXlsx {
+
+ ZipReader::ZipReader(const QString &filePath) :
+- m_reader(new Stel::QZipReader(filePath))
++ m_reader(new QZipReader(filePath))
+ {
+ init();
+ }
+
+ ZipReader::ZipReader(QIODevice *device) :
+- m_reader(new Stel::QZipReader(device))
++ m_reader(new QZipReader(device))
+ {
+ init();
+ }
+@@ -45,8 +45,8 @@
+
+ void ZipReader::init()
+ {
+- QList<Stel::QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
+- foreach (const Stel::QZipReader::FileInfo &fi, allFiles)
++ QList<QZipReader::FileInfo> allFiles = m_reader->fileInfoList();
++ foreach (const QZipReader::FileInfo &fi, allFiles)
+ {
+ if (fi.isFile)
+ m_filePaths.append(fi.filePath);
+diff -r 2019bb0d2919 xlsxzipreader_p.h
+--- a/src/external/qxlsx/xlsxzipreader_p.h Thu Oct 08 21:35:35 2020 +0100
++++ b/src/external/qxlsx/xlsxzipreader_p.h Thu Oct 08 21:36:28 2020 +0100
+@@ -38,7 +38,7 @@
+ //
+
+ #include "xlsxglobal.h"
+-#include "external/qtcompress/qzipreader.h"
++#include "qzipreader.h"
+ #include <QScopedPointer>
+ #include <QStringList>
+ #include <QVector>
+@@ -60,7 +60,7 @@
+ private:
+ Q_DISABLE_COPY(ZipReader)
+ void init();
+- QScopedPointer<Stel::QZipReader> m_reader;
++ QScopedPointer<QZipReader> m_reader;
+ QStringList m_filePaths;
+ };
+
+diff -r 11536448457a xlsxzipwriter.cpp
+--- a/src/external/qxlsx/xlsxzipwriter.cpp Thu Oct 08 21:41:22 2020 +0100
++++ b/src/external/qxlsx/xlsxzipwriter.cpp Thu Oct 08 21:42:03 2020 +0100
+@@ -29,14 +29,14 @@
+
+ ZipWriter::ZipWriter(const QString &filePath)
+ {
+- m_writer = new Stel::QZipWriter(filePath, QIODevice::WriteOnly);
+- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
++ m_writer = new QZipWriter(filePath, QIODevice::WriteOnly);
++ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
+ }
+
+ ZipWriter::ZipWriter(QIODevice *device)
+ {
+- m_writer = new Stel::QZipWriter(device);
+- m_writer->setCompressionPolicy(Stel::QZipWriter::AutoCompress);
++ m_writer = new QZipWriter(device);
++ m_writer->setCompressionPolicy(QZipWriter::AutoCompress);
+ }
+
+ ZipWriter::~ZipWriter()
+@@ -46,7 +46,7 @@
+
+ bool ZipWriter::error() const
+ {
+- return m_writer->status() != Stel::QZipWriter::NoError;
++ return m_writer->status() != QZipWriter::NoError;
+ }
+
+ void ZipWriter::addFile(const QString &filePath, QIODevice *device)
+diff -r 2019bb0d2919 xlsxzipwriter_p.h
+--- a/src/external/qxlsx/xlsxzipwriter_p.h Thu Oct 08 21:35:35 2020 +0100
++++ b/src/external/qxlsx/xlsxzipwriter_p.h Thu Oct 08 21:36:28 2020 +0100
+@@ -37,7 +37,7 @@
+ //
+
+ #include <QString>
+-#include "external/qtcompress/qzipwriter.h"
++#include "qzipwriter.h"
+
+ class QIODevice;
+ class QZipWriter;
+@@ -57,7 +57,7 @@
+ void close();
+
+ private:
+- Stel::QZipWriter *m_writer;
++ QZipWriter *m_writer;
+ };
+
+ } // namespace QXlsx
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch
new file mode 100644
index 000000000000..37acb83e667e
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch
@@ -0,0 +1,23 @@
+This patch is not really needed, because zlib is already used from system, but
+it makes it easier to ensure that nothing else is bundled
+
+diff --git a/src/external/CMakeLists.txt b/src/external/CMakeLists.txt
+index 834aff89cb..590579e501 100644
+--- a/src/external/CMakeLists.txt
++++ b/src/external/CMakeLists.txt
+@@ -36,6 +36,7 @@ target_link_libraries(glues_stel Qt5::Gui)
+ set_target_properties(glues_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(glues_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ SET(zlib_SRCS
+ zlib/adler32.c
+ zlib/compress.c
+@@ -69,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib)
+ #turn off automoc, not needed here
+ set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ if(0)
+ set(qtcompress_SRCS