summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-12-09 12:50:45 +0100
committerSam James <sam@gentoo.org>2022-12-24 06:59:44 +0000
commit09607a4dd3014f1373b1437f06d4aa0e1bce4633 (patch)
treeacef19dc43f64f2c099cee0d147afcf355577b6b /sci-astronomy
parentnet-im/telegram-desktop-bin: bump version to 4.4.1 (diff)
downloadgentoo-09607a4dd3014f1373b1437f06d4aa0e1bce4633.tar.gz
gentoo-09607a4dd3014f1373b1437f06d4aa0e1bce4633.tar.bz2
gentoo-09607a4dd3014f1373b1437f06d4aa0e1bce4633.zip
sci-astronomy/xephem: enable parallel build
- add a patch to allow parallel builds - add remote-id to make pkgcheck happy - update obsolete virtual/jpeg dependency and order deps Closes: https://bugs.gentoo.org/881813 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/28610 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/xephem/files/xephem-4.1.0-allow-parallel-builds.patch26
-rw-r--r--sci-astronomy/xephem/metadata.xml3
-rw-r--r--sci-astronomy/xephem/xephem-4.1.0-r1.ebuild (renamed from sci-astronomy/xephem/xephem-4.1.0.ebuild)7
3 files changed, 34 insertions, 2 deletions
diff --git a/sci-astronomy/xephem/files/xephem-4.1.0-allow-parallel-builds.patch b/sci-astronomy/xephem/files/xephem-4.1.0-allow-parallel-builds.patch
new file mode 100644
index 000000000000..87d4a32e8857
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-4.1.0-allow-parallel-builds.patch
@@ -0,0 +1,26 @@
+From 89cc80f47cdf71d3a5eae0ea6a2bade329a3e1fb Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Fri, 9 Dec 2022 12:30:24 +0100
+Subject: [PATCH] allow parallel builds
+
+Ensure all libraries are ready before the final binary is
+going to get linked.
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/GUI/xephem/Makefile
++++ b/GUI/xephem/Makefile
+@@ -182,9 +182,9 @@ OBJS = \
+ xephem.o \
+ xmisc.o
+
+-all: libs xephem xephem.1
++all: xephem xephem.1
+
+-xephem: $(INCS) $(OBJS)
++xephem: libs $(INCS) $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ xephem.1: xephem.man
+--
+2.38.1
+
diff --git a/sci-astronomy/xephem/metadata.xml b/sci-astronomy/xephem/metadata.xml
index b68063e309e9..a6c852e0ab3d 100644
--- a/sci-astronomy/xephem/metadata.xml
+++ b/sci-astronomy/xephem/metadata.xml
@@ -13,4 +13,7 @@
the moons of Jupiter, Saturn and Earth; Mars' and Jupiter's central
meridian longitude; Saturn's rings; and Jupiter's Great Red Spot.
</longdescription>
+ <upstream>
+ <remote-id type="github">XEphem/XEphem</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-astronomy/xephem/xephem-4.1.0.ebuild b/sci-astronomy/xephem/xephem-4.1.0-r1.ebuild
index 8b8f87e5ba22..ef46be975575 100644
--- a/sci-astronomy/xephem/xephem-4.1.0.ebuild
+++ b/sci-astronomy/xephem/xephem-4.1.0-r1.ebuild
@@ -16,9 +16,9 @@ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-libs/openssl:=
- >=x11-libs/motif-2.3:0
- virtual/jpeg:0
+ media-libs/libjpeg-turbo:=
media-libs/libpng:0=
+ >=x11-libs/motif-2.3:0
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXt
@@ -28,9 +28,12 @@ BDEPEND="sys-apps/groff"
HTML_DOCS=( GUI/xephem/help/. )
+# NOTE: order is relevant - parallel build patch requires respect env vars
+# patch to be already applied
PATCHES=(
"${FILESDIR}/${PN}-3.7.7-implicits.patch"
"${FILESDIR}/${P}-respect_env_vars.patch"
+ "${FILESDIR}/${P}-allow-parallel-builds.patch"
)
src_compile() {