summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-10 10:34:16 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-10 10:52:21 +0100
commitbfc6c33552bb57d4e7e56686c91ae99e364e1bf3 (patch)
tree7a689a349de015ae20fcb4dd484f0e94c08d6cf1 /sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
parentapp-portage/unsymlink-lib: Bump to v11, with lib32 removal fix (diff)
downloadgentoo-bfc6c33552bb57d4e7e56686c91ae99e364e1bf3.tar.gz
gentoo-bfc6c33552bb57d4e7e56686c91ae99e364e1bf3.tar.bz2
gentoo-bfc6c33552bb57d4e7e56686c91ae99e364e1bf3.zip
sci-biology/libgtextutils: Initial addition
Closes: https://bugs.gentoo.org/486380 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild')
-rw-r--r--sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild b/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
new file mode 100644
index 000000000000..8f0455e5322c
--- /dev/null
+++ b/sci-biology/libgtextutils/libgtextutils-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Gordon Text utils Library"
+HOMEPAGE="http://hannonlab.cshl.edu/fastx_toolkit/"
+SRC_URI="http://hannonlab.cshl.edu/fastx_toolkit/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
+}