summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/plink/files/1.07-flags.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/plink/files/1.07-flags.patch')
-rw-r--r--sci-biology/plink/files/1.07-flags.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/plink/files/1.07-flags.patch b/sci-biology/plink/files/1.07-flags.patch
new file mode 100644
index 000000000000..aa130f29beb2
--- /dev/null
+++ b/sci-biology/plink/files/1.07-flags.patch
@@ -0,0 +1,44 @@
+diff --git a/Makefile b/Makefile
+index 172c795..466f09f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,25 +26,25 @@ WITH_R_PLUGINS = 1
+ WITH_WEBCHECK = 1
+ FORCE_32BIT =
+ WITH_ZLIB = 1
+-WITH_LAPACK =
+-FORCE_DYNAMIC =
++WITH_LAPACK = 1
++FORCE_DYNAMIC = 1
+
+ # Put C++ compiler here; Windows has it's own specific version
+ CXX_UNIX = g++
+ CXX_WIN = c:\bin\mingw\bin\mingw32-g++.exe
+
+ # Any other compiler flags here ( -Wall, -g, etc)
+-CXXFLAGS =
++CXXFLAGS ?= -O2
+
+ # Misc
+-LIB_LAPACK = /usr/lib/liblapack.so.3
++LIB_LAPACK = `$(PKG_CONFIG) --libs lapack`
+
+
+ # --------------------------------------------------------------------
+ # Do not edit below this line
+ # --------------------------------------------------------------------
+
+-CXXFLAGS += -O3 -I.
++CXXFLAGS += -I.
+ OUTPUT = plink
+
+ # Some system specific flags
+@@ -151,7 +151,7 @@ OBJ = $(SRC:.cpp=.o)
+ all : $(OUTPUT)
+
+ $(OUTPUT) :
+- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
+
+ $(OBJ) : $(HDR)
+