summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/autodock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/autodock')
-rw-r--r--sci-chemistry/autodock/Manifest1
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6.ebuild102
-rw-r--r--sci-chemistry/autodock/files/4.0.1-gcc-4.3.patch10
-rw-r--r--sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch44
-rw-r--r--sci-chemistry/autodock/metadata.xml5
5 files changed, 162 insertions, 0 deletions
diff --git a/sci-chemistry/autodock/Manifest b/sci-chemistry/autodock/Manifest
new file mode 100644
index 000000000000..422cb216787f
--- /dev/null
+++ b/sci-chemistry/autodock/Manifest
@@ -0,0 +1 @@
+DIST autodocksuite-4.2.6-src.tar.gz 35438010 SHA256 4b24ce4baf216a5e1a6a79bb664eeed684aed17cede64ff0061aa1bcc17874c4 SHA512 75b8878f948c4f6bc28adb442997192dad0c36bbede2fd698623903cb27b06b4df3ba038bfc70fc13b4bdee864fd2344f0f7208be2020da4e01a00b842b46bbb WHIRLPOOL 18230783d13c2d82ad6427711a48dec0c6695301a52dcf419cf4feefb0b5f41bac5de53824313e75d9040ac8623915ba266e764e92ecad9869d845053ec60b93
diff --git a/sci-chemistry/autodock/autodock-4.2.6.ebuild b/sci-chemistry/autodock/autodock-4.2.6.ebuild
new file mode 100644
index 000000000000..10d018292e93
--- /dev/null
+++ b/sci-chemistry/autodock/autodock-4.2.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-any-r1 versionator
+
+MY_PN="autodocksuite"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A suite of automated docking tools"
+HOMEPAGE="http://autodock.scripps.edu/"
+SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(delete_all_version_separators)/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples openmp test"
+
+RDEPEND=""
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+S="${WORKDIR}/src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_prepare() {
+ local i
+
+ epatch ${PATCHES[@]}
+
+ sed \
+ -e "s/\tcsh/\tsh/" \
+ -i auto{dock,grid}/Makefile.am || die
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ eautoreconf
+ popd &>/dev/null
+ done
+}
+
+src_configure() {
+ local i
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ econf $(use_enable openmp)
+ popd &>/dev/null
+ done
+}
+
+src_compile() {
+ emake -C autodock
+ emake -C autogrid
+}
+
+src_test() {
+ elog "Testing autodock"
+ cd "${S}/autodock/Tests" || die
+ cp ../*.dat . || die
+ ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+ einfo "Testing autogrid"
+ cd "${S}/autogrid/Tests" || die
+ ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+}
+
+src_install() {
+ if use openmp; then
+ newbin autodock/autodock4.omp ${PN}4
+ dobin autogrid/autogrid4
+ else
+ dobin autodock/autodock4 autogrid/autogrid4
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r \
+ autodock/{AD4_parameters.dat,AD4_PARM99.dat} \
+ $(usex examples "autodoc/EXAMPLES" "")
+
+ DOCS=(
+ RELEASENOTES
+ autodock/{AUTHORS,README}
+ autodock/USERGUIDES/AutoDock4.{0,1,2}_UserGuide.doc
+ autodock/USERGUIDES/AutoDock4.2_UserGuide.pdf
+ )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "The AutoDock development team requests all users to fill out the"
+ elog "registration form at:"
+ echo
+ elog "\thttp://autodock.scripps.edu/downloads/autodock-registration"
+ echo
+ elog "The number of unique users of AutoDock is used by Prof. Arthur J."
+ elog "Olson and the Scripps Research Institude to support grant"
+ elog "applications."
+}
diff --git a/sci-chemistry/autodock/files/4.0.1-gcc-4.3.patch b/sci-chemistry/autodock/files/4.0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..b9eb3c409c64
--- /dev/null
+++ b/sci-chemistry/autodock/files/4.0.1-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- autodocksuite-4.0.1.orig/src/autogrid/check_size.cpp 2008-08-04 22:44:46.000000000 -0700
++++ autodocksuite-4.0.1/src/autogrid/check_size.cpp 2008-08-04 22:45:12.000000000 -0700
+@@ -27,6 +27,7 @@
+
+ #include <iostream>
+ #include <math.h>
++#include <cstdlib>
+ #include "autogrid.h"
+
+
diff --git a/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
new file mode 100644
index 000000000000..ae44ffeb3159
--- /dev/null
+++ b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
@@ -0,0 +1,44 @@
+ src/autodock/Makefile.am | 6 +++---
+ src/autogrid/Makefile.am | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/autodock/Makefile.am b/src/autodock/Makefile.am
+index 799a3c4..911897b 100644
+--- a/src/autodock/Makefile.am
++++ b/src/autodock/Makefile.am
+@@ -459,7 +459,8 @@ endif
+
+ BUILT_SOURCES = $(autodock4_SOURCES) default_parameters.h
+
+-AM_CXXFLAGS = -O3 # Agressive optimization
++AM_CXXFLAGS =
++#AM_CXXFLAGS = -O3 # Agressive optimization
+ #AM_CXXFLAGS = -g # debug
+
+ # if gnu c++ compiler
+@@ -488,8 +489,7 @@ endif
+ AM_CPPFLAGS = -DNOSQRT \
+ -DUSE_DOUBLE \
+ -DUSE_8A_NBCUTOFF \
+- -DUSE_INT_AS_FOURBYTELONG \
+- -O3
++ -DUSE_INT_AS_FOURBYTELONG
+ # AM_LDFLAGS = -g # -g is MP debug
+
+
+diff --git a/src/autogrid/Makefile.am b/src/autogrid/Makefile.am
+index b531099..b78b380 100644
+--- a/src/autogrid/Makefile.am
++++ b/src/autogrid/Makefile.am
+@@ -94,9 +94,9 @@ autogrid4_SOURCES = main.cpp \
+ BUILT_SOURCES = default_parameters.h
+
+
+-AM_CFLAGS = -Wall -O3 # All warnings, Agressive optimization
++AM_CFLAGS = -Wall # All warnings, Agressive optimization
+
+-AM_CPPFLAGS = -Wall -O3 -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
++AM_CPPFLAGS = -Wall -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
+ AM_CPPFLAGS += -Wno-write-strings # increase compatibility with pre 4.x compilers for string handling
+ # M Pique - add USE_8A_NBCUTOFF
+ AM_CPPFLAGS += -DUSE_8A_NBCUTOFF
diff --git a/sci-chemistry/autodock/metadata.xml b/sci-chemistry/autodock/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-chemistry/autodock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>