summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/babel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/babel')
-rw-r--r--sci-chemistry/babel/Manifest1
-rw-r--r--sci-chemistry/babel/babel-1.6-r1.ebuild37
-rw-r--r--sci-chemistry/babel/files/10babel1
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gcc32.diff28
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gentoo.diff28
-rw-r--r--sci-chemistry/babel/files/babel-1.6-makefile.patch33
-rw-r--r--sci-chemistry/babel/metadata.xml5
7 files changed, 133 insertions, 0 deletions
diff --git a/sci-chemistry/babel/Manifest b/sci-chemistry/babel/Manifest
new file mode 100644
index 000000000000..c710a51eca7e
--- /dev/null
+++ b/sci-chemistry/babel/Manifest
@@ -0,0 +1 @@
+DIST babel-1.6.tar.Z 242341 SHA256 132a800cfe0c15b47391c809481a7ca174bbd1402aac7486e0973da0fd4db948 SHA512 60336f695b8ee3ec87433b003da38d55365162bbe87244cb175eabec6c0a470c475dac66f85f24525a61b16fa933bdc3eea5ddd0452b6573bcb046ab774b3229 WHIRLPOOL f6dee4fe6409aed0dfae3f672c826ccdb45f0f5d743421faf6622e1258435caf7d9259ece83ab711754a7964bca0c21af42ed179af23b056329d8b800bd95e80
diff --git a/sci-chemistry/babel/babel-1.6-r1.ebuild b/sci-chemistry/babel/babel-1.6-r1.ebuild
new file mode 100644
index 000000000000..1905b34846f0
--- /dev/null
+++ b/sci-chemistry/babel/babel-1.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Interconvert file formats used in molecular modeling"
+HOMEPAGE="http://smog.com/chem/babel/"
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+RESTRICT="mirror bindist"
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="!sci-chemistry/openbabel"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc32.diff \
+ "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+}
+
+src_install () {
+ emake DESTDIR="${D}"/usr/bin install
+
+ insinto /usr/share/${PN}
+ doins *.lis
+
+ doenvd "${FILESDIR}"/10babel
+ dodoc README.1ST
+}
diff --git a/sci-chemistry/babel/files/10babel b/sci-chemistry/babel/files/10babel
new file mode 100644
index 000000000000..69f3397638dd
--- /dev/null
+++ b/sci-chemistry/babel/files/10babel
@@ -0,0 +1 @@
+BABEL_DIR=/usr/share/babel
diff --git a/sci-chemistry/babel/files/babel-1.6-gcc32.diff b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
new file mode 100644
index 000000000000..ba0964af5352
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
@@ -0,0 +1,28 @@
+--- block.c.orig Sun Sep 15 04:51:13 2002
++++ block.c Sun Sep 15 04:58:04 2002
+@@ -99,7 +99,12 @@
+ void *array;
+
+ /* calc how much space we are gonna need */
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ size = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
+@@ -116,7 +121,12 @@
+ /* set up the ptrs if we can alloc the memory */
+ if(*handle != NULL)
+ {
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ ptr = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
diff --git a/sci-chemistry/babel/files/babel-1.6-gentoo.diff b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
new file mode 100644
index 000000000000..77e2cb47ef03
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
@@ -0,0 +1,28 @@
+--- Makefile.orig Tue Oct 23 00:20:54 2001
++++ Makefile Tue Oct 23 00:33:36 2001
+@@ -1,11 +1,15 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++CC = gcc
+
+ PROGRAM = babel
+
++DEST = ${DESTDIR}/$(PROGRAM)
++
+ LDFLAGS =
+
+ LIBS =
+@@ -334,6 +338,7 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
++ install -d ${DESTDIR}
+ install -s $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
diff --git a/sci-chemistry/babel/files/babel-1.6-makefile.patch b/sci-chemistry/babel/files/babel-1.6-makefile.patch
new file mode 100644
index 000000000000..33b158d1b2cf
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-makefile.patch
@@ -0,0 +1,33 @@
+diff -Naur babel-1.6/Makefile babel-1.6.new/Makefile
+--- babel-1.6/Makefile 1997-01-21 10:53:05.000000000 -0500
++++ babel-1.6.new/Makefile 2008-10-19 10:41:42.000000000 -0400
+@@ -1,12 +1,16 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++#CC = gcc
+
+ PROGRAM = babel
+
+-LDFLAGS =
++DEST = ${DESTDIR}/$(PROGRAM)
++
++#LDFLAGS =
+
+ LIBS =
+
+@@ -334,7 +338,8 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
+- install -s $(PROGRAM) $(DEST)
++ install -d ${DESTDIR}
++ install $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
+
diff --git a/sci-chemistry/babel/metadata.xml b/sci-chemistry/babel/metadata.xml
new file mode 100644
index 000000000000..e42d0af60f42
--- /dev/null
+++ b/sci-chemistry/babel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>