summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/petrify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/petrify')
-rw-r--r--sci-electronics/petrify/Manifest1
-rw-r--r--sci-electronics/petrify/metadata.xml13
-rw-r--r--sci-electronics/petrify/petrify-4.2-r1.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-electronics/petrify/Manifest b/sci-electronics/petrify/Manifest
new file mode 100644
index 000000000000..d18573dc9932
--- /dev/null
+++ b/sci-electronics/petrify/Manifest
@@ -0,0 +1 @@
+DIST petrify-4.2-linux.tgz 1117093 SHA256 bd324a9a04c1786eb6826348c01d177e37ac101d3dde260f0c0f3dc8204c1e0f SHA512 d3cdc4991ec5084ec5b676d74a2af935459fadfa3479d09871f5a4723205b576ab8f3f91e44cd37a4c47c7ae687ead7e25c7aae3d6eae29d2896b3a215cb1980 WHIRLPOOL 14fbc93611684e5a24dd799e2b8ee85de47c7f7541f7fd92950432108663cb192ddf16f07ce3088de683c0a673ff2c3a608de76e32205ac257ff802e0c7a1408
diff --git a/sci-electronics/petrify/metadata.xml b/sci-electronics/petrify/metadata.xml
new file mode 100644
index 000000000000..617189f8bd24
--- /dev/null
+++ b/sci-electronics/petrify/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ Petrify is a tool for synthesis of Petri nets and asynchronous controllers.
+ Petrify is able to obtain Petri nets with some specific properties: pure, free
+ choice, unique choice, place irredundant, etc... The Petri nets accepted by
+ petrify can also be interpreted as Signal Transition Graphs describing the
+ behavior of asynchronous controllers. Petrify is able to solve the Complete
+ State Coding problem and generate a speed-independent circuit.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-electronics/petrify/petrify-4.2-r1.ebuild b/sci-electronics/petrify/petrify-4.2-r1.ebuild
new file mode 100644
index 000000000000..4087180d3833
--- /dev/null
+++ b/sci-electronics/petrify/petrify-4.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Synthesize Petri nets into asynchronous circuits"
+HOMEPAGE="http://www.lsi.upc.edu/~jordicf/petrify/"
+SRC_URI="http://www.lsi.upc.edu/~jordicf/petrify/distrib/petrify-4.2-linux.tgz"
+
+LICENSE="Old-MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-gfx/graphviz"
+DEPEND=""
+
+RESTRICT="strip"
+
+QA_PREBUILT="/opt/petrify/petrify"
+
+S="${WORKDIR}"/${PN}
+
+src_install () {
+ exeinto /opt/petrify
+ doexe bin/petrify lib/petrify.lib
+ dosym petrify /opt/petrify/draw_astg
+ dosym petrify /opt/petrify/write_sg
+
+ dodoc doc/*
+ doman man/man1/*
+
+ dodir /etc/env.d
+ echo "PATH=${EPREFIX}/opt/petrify" > "${ED}"/etc/env.d/00petrify
+}