summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/spice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/spice')
-rw-r--r--sci-electronics/spice/Manifest1
-rw-r--r--sci-electronics/spice/files/spice-3.5.5-gcc-4.1.patch69
-rw-r--r--sci-electronics/spice/metadata.xml14
-rw-r--r--sci-electronics/spice/spice-3.5.5-r1.ebuild69
4 files changed, 153 insertions, 0 deletions
diff --git a/sci-electronics/spice/Manifest b/sci-electronics/spice/Manifest
new file mode 100644
index 000000000000..366305c0328b
--- /dev/null
+++ b/sci-electronics/spice/Manifest
@@ -0,0 +1 @@
+DIST spice3f5sfix.tar.gz 1377263 SHA256 8df74cc3d12f0e2c32c8455008ae4bf837e736edec9cedbc68c86b72e20abf5d
diff --git a/sci-electronics/spice/files/spice-3.5.5-gcc-4.1.patch b/sci-electronics/spice/files/spice-3.5.5-gcc-4.1.patch
new file mode 100644
index 000000000000..aea002d372c9
--- /dev/null
+++ b/sci-electronics/spice/files/spice-3.5.5-gcc-4.1.patch
@@ -0,0 +1,69 @@
+diff -Nadurp spice3f5sfix.orig/src/lib/fte/graf.c spice3f5sfix/src/lib/fte/graf.c
+--- spice3f5sfix.orig/src/lib/fte/graf.c 1999-06-11 14:38:56.000000000 +0200
++++ spice3f5sfix/src/lib/fte/graf.c 2006-05-21 21:49:52.000000000 +0200
+@@ -52,6 +52,9 @@ double *readtics();
+ #define XFACTOR 2 /* How much to expand the X scale during iplot. */
+ #define YFACTOR 1.5 /* How much to expand the Y scale during iplot. */
+
++static drawlegend();
++static gr_resize_internal();
++
+ /*
+ * Start of a new graph.
+ * Fill in the data that gets displayed.
+diff -Nadurp spice3f5sfix.orig/src/lib/fte/grid.c spice3f5sfix/src/lib/fte/grid.c
+--- spice3f5sfix.orig/src/lib/fte/grid.c 1999-05-30 09:14:12.000000000 +0200
++++ spice3f5sfix/src/lib/fte/grid.c 2006-05-21 21:49:52.000000000 +0200
+@@ -34,6 +34,9 @@ typedef enum { x_axis, y_axis } Axis;
+ ie, can get rid of it */
+ static bool scaleunits = true;
+
++static drawlingrid();
++static drawloggrid();
++
+ void
+ gr_fixgrid(graph, xdelta, ydelta, xtype, ytype)
+ GRAPH *graph;
+diff -Nadurp spice3f5sfix.orig/src/lib/fte/x11.c spice3f5sfix/src/lib/fte/x11.c
+--- spice3f5sfix.orig/src/lib/fte/x11.c 1999-06-19 14:09:37.000000000 +0200
++++ spice3f5sfix/src/lib/fte/x11.c 2006-05-21 21:50:35.000000000 +0200
+@@ -81,6 +81,10 @@ static GRAPH *lasthardcopy; /* graph use
+ static int X11_Open = 0;
+ static int numdispplanes;
+
++static initlinestyles();
++static initcolors();
++static X_ScreentoData();
++
+ X11_Init()
+ {
+
+diff -Nadurp spice3f5sfix.orig/src/lib/hlp/readhelp.c spice3f5sfix/src/lib/hlp/readhelp.c
+--- spice3f5sfix.orig/src/lib/hlp/readhelp.c 1993-06-17 23:32:43.000000000 +0200
++++ spice3f5sfix/src/lib/hlp/readhelp.c 2006-05-21 21:49:52.000000000 +0200
+@@ -41,8 +41,8 @@ Author: 1986 Wayne A. Christopher, U. C.
+
+ static char *getsubject();
+ static toplink *getsubtoplink();
+-extern void sortlist(), tlfree();
+-extern int sortcmp();
++static void sortlist(), tlfree();
++static int sortcmp();
+
+ static topic *alltopics = NULL;
+
+diff -Nadurp spice3f5sfix.orig/src/lib/mfb/mfbcaps.c spice3f5sfix/src/lib/mfb/mfbcaps.c
+--- spice3f5sfix.orig/src/lib/mfb/mfbcaps.c 1993-06-17 23:34:25.000000000 +0200
++++ spice3f5sfix/src/lib/mfb/mfbcaps.c 2006-05-21 21:49:52.000000000 +0200
+@@ -43,9 +43,9 @@ static int hopcount; /* detect inf
+
+ FILE *POpen();
+ char *strcpy();
+-char *MFBSkip();
++static char *MFBSkip();
+ char *MFBGetStr();
+-char *MFBCapDecod();
++static char *MFBCapDecod();
+ int MFBGetNum();
+ int MFBGetFlag();
+ int MFBGetEnt();
diff --git a/sci-electronics/spice/metadata.xml b/sci-electronics/spice/metadata.xml
new file mode 100644
index 000000000000..90ad22c07fd3
--- /dev/null
+++ b/sci-electronics/spice/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ SPICE is a general-purpose circuit simulation program for nonlinear dc,
+ nonlinear transient, and linear ac analyses. Circuits may contain resistors,
+ capacitors, inductors, mutual inductors, independent voltage and current
+ sources, four types of dependent sources, lossless and lossy transmission
+ lines (two separate implementations), switches, uniform distributed RC lines,
+ and the five most common semiconductor devices: diodes, BJTs, JFETs, MESFETs,
+ and MOSFETs.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-electronics/spice/spice-3.5.5-r1.ebuild b/sci-electronics/spice/spice-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..441f8752cfa0
--- /dev/null
+++ b/sci-electronics/spice/spice-3.5.5-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic multilib
+
+IUSE=""
+
+MY_P="spice3f5sfix"
+DESCRIPTION="general-purpose circuit simulation program"
+HOMEPAGE="http://bwrc.eecs.berkeley.edu/Classes/IcBook/SPICE/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/circuits/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="sys-libs/ncurses
+ x11-libs/libXaw
+ >=app-misc/editor-wrapper-3"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ # spice accepts -O1 at most
+ replace-flags -O* -O1
+
+ unpack ${A}
+ cd "${S}"
+ # Avoid re-creating WORKDIR due to stupid mtime
+ touch ..
+
+ sed -i -e "s:termcap:ncurses:g" \
+ -e "s:joe:/usr/libexec/editor:g" \
+ -e "s:-O2 -s:${CFLAGS}:g" \
+ -e "s:-lncurses -lm -s:-lncurses -lm ${LDFLAGS}:" \
+ -e "s:SPICE_DIR)/lib:SPICE_DIR)/$(get_libdir)/spice:g" \
+ -e "s:/usr/local/spice:/usr:g" \
+ -e "s:/X11R6::" \
+ conf/linux || die
+ sed -i -e "s:head -1:head -n 1:" util/build || die
+ epatch "${FILESDIR}"/${P}-gcc-4.1.patch
+
+ # fix possible buffer overflow (bug #339539)
+ sed -i -e "s:fgets(buf, BSIZE_SP:fgets(buf, sizeof(buf):g" \
+ src/lib/fte/misccoms.c || die
+}
+
+src_compile() {
+ ./util/build linux || die "build failed"
+ obj/bin/makeidx lib/helpdir/spice.txt || die "makeidx failed"
+}
+
+src_install() {
+ # install binaries
+ dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod} || die "failed to copy binaries"
+ newbin obj/bin/help spice.help || die
+ dosym /usr/bin/spice3 /usr/bin/spice || die
+ # install runtime stuff
+ rm -f lib/make*
+ dodir /usr/$(get_libdir)/spice || die
+ cp -R lib/* "${D}"/usr/$(get_libdir)/spice/ || die "failed to copy libraries"
+ # install docs
+ doman man/man1/*.1 || die
+ dodoc readme readme.Linux notes/spice2 || die
+}