summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-21 01:28:39 -0400
committerSam James <sam@gentoo.org>2024-03-21 05:57:41 +0000
commit12bd3b6d3f2239776739e854f01b4dbc02f3c91b (patch)
tree4f02f293866cab9b70db695edc954d544c207327 /sci-electronics
parentsci-electronics/geda: remove useless USE conditionals that never fired (diff)
downloadgentoo-12bd3b6d3f2239776739e854f01b4dbc02f3c91b.tar.gz
gentoo-12bd3b6d3f2239776739e854f01b4dbc02f3c91b.tar.bz2
gentoo-12bd3b6d3f2239776739e854f01b4dbc02f3c91b.zip
sci-electronics/geda: avoid fatal warning for maybe-uninitialized
LTO makes the compiler better able to spot this. But it isn't something the entire build should fail due to, not for stable release tags of existing software. Closes: https://bugs.gentoo.org/862453 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/geda/geda-1.10.2-r2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sci-electronics/geda/geda-1.10.2-r2.ebuild b/sci-electronics/geda/geda-1.10.2-r2.ebuild
index 4d2d3cab6699..7983738c270b 100644
--- a/sci-electronics/geda/geda-1.10.2-r2.ebuild
+++ b/sci-electronics/geda/geda-1.10.2-r2.ebuild
@@ -62,6 +62,10 @@ src_prepare() {
rm docs/wiki/media/geda/pcb_plugin_template.tar.gz || die
rm docs/wiki/media/pcb/plugin_debug_window.tar.gz || die
+ # -Wmaybe-uninitialized is made fatal, which is not ideal for building
+ # releases. Upstream is working on fixing these anyway.
+ sed -i '/Werror_maybe_uninitialized_IF_SUPPORTED/d' configure.ac
+
eautoreconf
}