summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-10-07 18:35:15 -0700
committerMatthew Smith <matthew@gentoo.org>2022-11-05 09:01:10 +0000
commit1693760f5a996482804d96deabf8da73aa1e6b3f (patch)
tree4d1869ae41621fead9f5f498993f129231bfd774 /sci-electronics
parentsci-electronics/kicad: remove obsolete optfeature (diff)
downloadgentoo-1693760f5a996482804d96deabf8da73aa1e6b3f.tar.gz
gentoo-1693760f5a996482804d96deabf8da73aa1e6b3f.tar.bz2
gentoo-1693760f5a996482804d96deabf8da73aa1e6b3f.zip
sci-electronics/kicad-footprints: add 6.0.8
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-6.0.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index ea653a2182a4..1b3e91f0e3fe 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,3 +1,4 @@
DIST kicad-footprints-5.1.12.tar.bz2 3382783 BLAKE2B 6f7725bebd6099d86780ed2582aacfb3abff4db6065a6a17fcd7631782a0c2e1e8a23064f80cd95c79bbaca8da52003f01fce7e398e95596e45f15b144eeef7f SHA512 e717886dc742f37b626226065953a36829b50f9bf203efe1dbeab41d4dbe3a898bd65fbde9fa059ea9374ea92905faeb0ccd19dfb1a62f2d6a445c07f90b89a9
DIST kicad-footprints-6.0.6.tar.gz 31647789 BLAKE2B 3af7027987b25c4a3ee19925acaa539cea643656e1662f0b80ec76c807aca9ef7433228fc88cdd0c34b80e7bbb886abd5c11765983e9adc5b347ce01bd4b51c4 SHA512 6d93a90bfc0b246c70b336aa9265a051a33d8b490a81271fb85ab73cd19184a031f3429ce8ae9e1650ece475a30f0f283c43c5bb2d1f427b4129d4ed61480ac0
DIST kicad-footprints-6.0.7.tar.gz 31657956 BLAKE2B 127ac81c83841919903b300af89c2126e1f53ff1c03d6dcd2466eac8d4733da4f923831e24aa43fca2b5c6d9ee4389bd67f0bd2b4d300adb5356e261b14e897e SHA512 e0959846e057df46e38385d1fe71895930435fc51ad03bbc893481264d969d9739967b069855b59341388fec5458a4f2c71c527b7af7357437c5606c91f5436d
+DIST kicad-footprints-6.0.8.tar.gz 31697942 BLAKE2B f70d818b766ab2175ce638ced1d632b575b59c28167de037048ea49175448920a69458067c3cfe3237cc58ba08157a6fc7ffb34b96d17d64f32dd9bda5dc19e0 SHA512 e839e0b75657c76473cf6455f6c6c32ecd03d049e86ebb4abbf80e02de56e132fa0d32fc2b9e730d24dbd6cf770791589f9a0d8c2341cc8597705bf33edd4687
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-6.0.8.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-6.0.8.ebuild
new file mode 100644
index 000000000000..e1268b9afd0d
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-6.0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${MY_PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-6.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi