summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/Shapely
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/Manifest2
-rw-r--r--sci-libs/Shapely/Shapely-1.3.0.ebuild29
-rw-r--r--sci-libs/Shapely/Shapely-1.3.2.ebuild29
-rw-r--r--sci-libs/Shapely/Shapely-9999.ebuild28
-rw-r--r--sci-libs/Shapely/files/setup_unicode.patch23
-rw-r--r--sci-libs/Shapely/metadata.xml10
6 files changed, 121 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/Shapely/Manifest
new file mode 100644
index 000000000000..6d0ebde8b8d9
--- /dev/null
+++ b/sci-libs/Shapely/Manifest
@@ -0,0 +1,2 @@
+DIST Shapely-1.3.0.tar.gz 118863 SHA256 297df004aec27e38ed93987e93ff5f8187cd0299394fe8b0b9028566015a9bb5 SHA512 106f9773a5b00e7269a84c760f3a2b867c48139c48eebeecd524c8216d75c28daaf46eff45c118c1809999e33a317e9aca278a8d83605dc7273877a7ed3edd82 WHIRLPOOL ddf42cab233b0950a4a955070c5a2a7791a7f259ba857778689944c7799484f7c1aa710926c37c8c66deaae5ab4f03d79fa2f407e8e6d05238217b529e7b1b15
+DIST Shapely-1.3.2.tar.gz 120179 SHA256 9f0de51c71373fcee4962f79f4813d67ea1e711f4394d7636c929a4019c5c2ff SHA512 23d65c5a7137726e05e0399dc49f05e5ad9b582d4adcdf30215f72ae75989e85daf30ea2a5010d6a5a086cb6bbb5b4599b5065080b845c833776812f6e46566d WHIRLPOOL 37836bd5597e485fe4ac8bb0994724fd7cde59bc2d57becd0e89547c0b561d147ff9bea3d99b1429c8a163538a7af7deb8416a4e5dfb8c9f7dff5322e81b2fb6
diff --git a/sci-libs/Shapely/Shapely-1.3.0.ebuild b/sci-libs/Shapely/Shapely-1.3.0.ebuild
new file mode 100644
index 000000000000..aca63508a63c
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/setup_unicode.patch )
+
+python_test() {
+ esetup.py test
+}
diff --git a/sci-libs/Shapely/Shapely-1.3.2.ebuild b/sci-libs/Shapely/Shapely-1.3.2.ebuild
new file mode 100644
index 000000000000..aca63508a63c
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/setup_unicode.patch )
+
+python_test() {
+ esetup.py test
+}
diff --git a/sci-libs/Shapely/Shapely-9999.ebuild b/sci-libs/Shapely/Shapely-9999.ebuild
new file mode 100644
index 000000000000..1b3020d48ddd
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/sci-libs/Shapely/files/setup_unicode.patch b/sci-libs/Shapely/files/setup_unicode.patch
new file mode 100644
index 000000000000..89e1b058f0f8
--- /dev/null
+++ b/sci-libs/Shapely/files/setup_unicode.patch
@@ -0,0 +1,23 @@
+--- setup.py.orig 2014-06-20 10:27:26.638779565 +0200
++++ setup.py 2014-06-20 10:27:29.885446151 +0200
+@@ -1,4 +1,5 @@
+ #!/usr/bin/env python
++# -*- coding: utf-8 -*-
+
+ from __future__ import print_function
+
+@@ -74,8 +75,12 @@
+ readme_text = fp.read()
+ readme_text = readme_text.replace(".. include:: CREDITS.txt", "")
+
+-with open('CREDITS.txt', 'r') as fp:
+- credits = fp.read()
++if sys.version_info[0] == 3:
++ with open('CREDITS.txt', 'r', encoding='utf-8') as fp:
++ credits = fp.read()
++elif sys.version_info[0] == 2:
++ with open('CREDITS.txt', 'r') as fp:
++ credits = fp.read().decode('utf-8')
+
+ with open('CHANGES.txt', 'r') as fp:
+ changes_text = fp.read()
diff --git a/sci-libs/Shapely/metadata.xml b/sci-libs/Shapely/metadata.xml
new file mode 100644
index 000000000000..ed7978de6acf
--- /dev/null
+++ b/sci-libs/Shapely/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Shapely</remote-id>
+ </upstream>
+</pkgmetadata>