summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-26 05:16:59 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:32 +0000
commit34e20a3becdb0dd30f434c8bf6f1c6050ef3b261 (patch)
treee92d1ed8a3676e28316867b6263f3e21a1c19255 /sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
parentsci-libs/coinor-mp: bump to 1.8.4, ported to EAPI 7 (diff)
downloadgentoo-34e20a3becdb0dd30f434c8bf6f1c6050ef3b261.tar.gz
gentoo-34e20a3becdb0dd30f434c8bf6f1c6050ef3b261.tar.bz2
gentoo-34e20a3becdb0dd30f434c8bf6f1c6050ef3b261.zip
sci-libs/coinor-mp: remove old
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild')
-rw-r--r--sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild b/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
deleted file mode 100644
index f8d827e01c64..000000000000
--- a/sci-libs/coinor-mp/coinor-mp-1.7.6.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYPN=CoinMP
-
-DESCRIPTION="COIN-OR lightweight API for COIN-OR libraries CLP, CBC, and CGL"
-HOMEPAGE="https://projects.coin-or.org/CoinMP/"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-
-LICENSE="EPL-1.0"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples static-libs"
-
-RDEPEND="sci-libs/coinor-cbc:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- # needed for the --with-coin-instdir
- dodir /usr
- sed -i \
- -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
- configure || die
- sed -i \
- -e '/^addlibsdir/s/$(DESTDIR)//' \
- -e 's/$(addlibsdir)/$(DESTDIR)\/$(addlibsdir)/g' \
- -e 's/$(DESTDIR)$(DESTDIR)/$(DESTDIR)/g' \
- Makefile.in || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-dependency-linking
- --with-coin-instdir="${ED}"/usr
- --datadir=/usr/share
- )
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_test test
-}
-
-src_install() {
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}