summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-19 13:44:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-19 13:45:11 +0100
commit1bfbb2fbe5f743bae7d83aa5e5849bf42efa25c7 (patch)
tree0aa2a36b4eb69595ccf8d87690529750422dcb8e /sci-libs/scipy
parentsys-kernel/hardened-sources: version bump to 4.9.16 (diff)
downloadgentoo-1bfbb2fbe5f743bae7d83aa5e5849bf42efa25c7.tar.gz
gentoo-1bfbb2fbe5f743bae7d83aa5e5849bf42efa25c7.tar.bz2
gentoo-1bfbb2fbe5f743bae7d83aa5e5849bf42efa25c7.zip
sci-libs/scipy: Do not glob on DISTDIR
Bug: https://bugs.gentoo.org/show_bug.cgi?id=612920 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/scipy-0.15.1.ebuild4
-rw-r--r--sci-libs/scipy/scipy-0.16.0.ebuild4
-rw-r--r--sci-libs/scipy/scipy-0.16.1.ebuild2
-rw-r--r--sci-libs/scipy/scipy-0.17.0.ebuild2
-rw-r--r--sci-libs/scipy/scipy-0.18.1.ebuild2
5 files changed, 7 insertions, 7 deletions
diff --git a/sci-libs/scipy/scipy-0.15.1.ebuild b/sci-libs/scipy/scipy-0.15.1.ebuild
index 21b523cf8c51..e228f7d3d4dc 100644
--- a/sci-libs/scipy/scipy-0.15.1.ebuild
+++ b/sci-libs/scipy/scipy-0.15.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -123,7 +123,7 @@ sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
python_install_all() {
if use doc; then
- dodoc "${DISTDIR}"/${PN}*pdf
+ dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
docinto html
dodoc -r "${WORKDIR}"/html/.
fi
diff --git a/sci-libs/scipy/scipy-0.16.0.ebuild b/sci-libs/scipy/scipy-0.16.0.ebuild
index 5cc5d81af807..e404280c5804 100644
--- a/sci-libs/scipy/scipy-0.16.0.ebuild
+++ b/sci-libs/scipy/scipy-0.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -125,7 +125,7 @@ python_test() {
python_install_all() {
if use doc; then
- dodoc "${DISTDIR}"/${PN}*pdf
+ dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
docinto html
dodoc -r "${WORKDIR}"/html/.
fi
diff --git a/sci-libs/scipy/scipy-0.16.1.ebuild b/sci-libs/scipy/scipy-0.16.1.ebuild
index 2b2cbdd32e20..dd5908fb2319 100644
--- a/sci-libs/scipy/scipy-0.16.1.ebuild
+++ b/sci-libs/scipy/scipy-0.16.1.ebuild
@@ -130,7 +130,7 @@ python_test() {
python_install_all() {
if use doc; then
- dodoc "${DISTDIR}"/${PN}*pdf
+ dodoc "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf
docinto html
dodoc -r "${WORKDIR}"/html/.
fi
diff --git a/sci-libs/scipy/scipy-0.17.0.ebuild b/sci-libs/scipy/scipy-0.17.0.ebuild
index 43d3e39d6371..ac2f5ad71e96 100644
--- a/sci-libs/scipy/scipy-0.17.0.ebuild
+++ b/sci-libs/scipy/scipy-0.17.0.ebuild
@@ -131,7 +131,7 @@ python_test() {
python_install_all() {
use doc && \
- local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+ local DOCS=( "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf ) \
local HTML_DOCS=( "${WORKDIR}"/html/. )
distutils-r1_python_install_all
}
diff --git a/sci-libs/scipy/scipy-0.18.1.ebuild b/sci-libs/scipy/scipy-0.18.1.ebuild
index 44a6f8669f15..c1d9ea57af22 100644
--- a/sci-libs/scipy/scipy-0.18.1.ebuild
+++ b/sci-libs/scipy/scipy-0.18.1.ebuild
@@ -130,7 +130,7 @@ python_test() {
python_install_all() {
use doc && \
- local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+ local DOCS=( "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf ) \
local HTML_DOCS=( "${WORKDIR}"/html/. )
distutils-r1_python_install_all
}