summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-08 12:41:39 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-08 12:48:52 -0400
commit054b45d46369d8501797b0108926556d7fafc598 (patch)
treee084fc5a826c28969c2312084c61b734dc84e355 /sci-libs
parentnet-dns/openresolv: remove non-existent blockers (diff)
downloadgentoo-054b45d46369d8501797b0108926556d7fafc598.tar.gz
gentoo-054b45d46369d8501797b0108926556d7fafc598.tar.bz2
gentoo-054b45d46369d8501797b0108926556d7fafc598.zip
sci-libs/volk: make ebuild less trash
also fix bug #727130 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/volk/volk-2.3.0-r1.ebuild45
-rw-r--r--sci-libs/volk/volk-2.3.0.ebuild34
2 files changed, 45 insertions, 34 deletions
diff --git a/sci-libs/volk/volk-2.3.0-r1.ebuild b/sci-libs/volk/volk-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..3d7fe8595e4d
--- /dev/null
+++ b/sci-libs/volk/volk-2.3.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+CMAKE_BUILD_TYPE="Release"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="orc"
+
+RDEPEND="!<net-wireless/gnuradio-3.8
+ dev-libs/boost:=
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')"
+
+RESTRICT="test"
+
+src_prepare() {
+ #https://github.com/gnuradio/volk/issues/382
+ #Waiting for confirmation from upstream to push this fix
+ #sed -i '/_mm256_zeroupper();/d' kernels/volk/volk_32f_x2_dot_prod_32f.h || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
diff --git a/sci-libs/volk/volk-2.3.0.ebuild b/sci-libs/volk/volk-2.3.0.ebuild
deleted file mode 100644
index f7a14102aec1..000000000000
--- a/sci-libs/volk/volk-2.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-DESCRIPTION="vector optimized library of kernels"
-HOMEPAGE="http://libvolk.org"
-SRC_URI="https://github.com/gnuradio/volk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+orc"
-
-RDEPEND="!<net-wireless/gnuradio-3.8
- dev-libs/boost
- dev-lang/orc"
-DEPEND="${RDEPEND}
- dev-python/mako
- dev-python/six"
-
-#https://github.com/gnuradio/volk/issues/382
-RESTRICT=test
-
-CMAKE_BUILD_TYPE=Release
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_ORC=$(usex orc)
- )
- cmake-utils_src_configure
-}