summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-11-08 00:37:22 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-15 11:02:20 +0100
commit3b1b3cda548ba95436f3cd6f27ba29ad96fa7a6b (patch)
treecff380ae845f49dd18f6f1d7b39534ec370ed9e9 /sci-libs
parentsys-kernel/dracut: add 060_pre20240104 (diff)
downloadgentoo-3b1b3cda548ba95436f3cd6f27ba29ad96fa7a6b.tar.gz
gentoo-3b1b3cda548ba95436f3cd6f27ba29ad96fa7a6b.tar.bz2
gentoo-3b1b3cda548ba95436f3cd6f27ba29ad96fa7a6b.zip
sci-libs/HighFive: 2.8.0 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/33718 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/HighFive/HighFive-2.8.0.ebuild62
-rw-r--r--sci-libs/HighFive/Manifest1
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/HighFive/HighFive-2.8.0.ebuild b/sci-libs/HighFive/HighFive-2.8.0.ebuild
new file mode 100644
index 000000000000..d642d1b78853
--- /dev/null
+++ b/sci-libs/HighFive/HighFive-2.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="app-text/doxygen[dot]"
+DOCS_DIR="doc"
+
+inherit cmake docs
+
+DESCRIPTION="Header-only C++ interface for libhdf5"
+HOMEPAGE="https://github.com/BlueBrain/HighFive"
+SRC_URI="https://github.com/BlueBrain/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="mpi test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/hdf5[mpi?]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-cpp/catch-3.4.0:0
+ dev-libs/boost
+ dev-cpp/eigen
+ media-libs/opencv
+ )
+"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_configure() {
+ default
+ local mycmakeargs=(
+ -DHIGHFIVE_PARALLEL_HDF5=$(usex mpi)
+
+ -DHIGHFIVE_USE_BOOST=$(usex test)
+ -DHIGHFIVE_USE_EIGEN=$(usex test)
+ -DHIGHFIVE_USE_OPENCV=$(usex test)
+ -DHIGHFIVE_USE_XTENSOR=OFF
+
+ -DHIGHFIVE_EXAMPLES=$(usex test)
+ -DHIGHFIVE_UNIT_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ default
+ use test && cmake_src_compile
+ use doc && doxygen_compile
+}
+
+src_test() {
+ # Set -j1 to prevent race
+ cmake_src_test -j1
+}
diff --git a/sci-libs/HighFive/Manifest b/sci-libs/HighFive/Manifest
index dec4fca0f6cb..f1140972d9a7 100644
--- a/sci-libs/HighFive/Manifest
+++ b/sci-libs/HighFive/Manifest
@@ -1 +1,2 @@
DIST HighFive-2.7.1.tar.gz 518596 BLAKE2B e2c499ff629bf1ef5ec62baffa71624f90099179a31a085ede4a027c1747ecad7da0f4964c755e77c0825ac3ef4006ead972a3e7b59103ebaa6bd1a552f57f42 SHA512 4fbbd3898791a67e44329a5d0e20e16454b9393510236563b12fe4346cd4f2785d43d915ea05239ac1568d00651e41d85d93590f01454ffc1b82e7bba28e780a
+DIST HighFive-2.8.0.tar.gz 538050 BLAKE2B ad856be95365c6d94add457d76366e0a3143fd09bbb6354048f896e16f5445d1037367eaaeaa233a3b5f9c45d2a2611173e051d2bd9e7aff4a3472665d96ec7f SHA512 cabcf8f1507b4466b7438249a813ea36de5e5d220c5caf7656312e24dbe09042bf9573388ca7c3caa22f71bd3b8106923710f9459127f87c341e2b0ab953eede