summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-28 14:39:49 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-28 14:40:20 +0100
commitb2ebfea24c268cef7c30cbea68442057993cb502 (patch)
treefe1ae247d3cda02d677565c430a449792974d8c2 /sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild
parentx11-drivers/nvidia-drivers: sync 460.91.03 ebuild with others (diff)
downloadgentoo-b2ebfea24c268cef7c30cbea68442057993cb502.tar.gz
gentoo-b2ebfea24c268cef7c30cbea68442057993cb502.tar.bz2
gentoo-b2ebfea24c268cef7c30cbea68442057993cb502.zip
sci-mathematics/alt-ergo: fix deps
Closes: https://bugs.gentoo.org/830140 Closes: https://bugs.gentoo.org/830156 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..52d3124f6809
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.4.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
+ >=sci-mathematics/psmt2-frontend-0.4.0:=
+
+ >=dev-ml/menhir-20181006:=
+ >=dev-ml/ocplib-simplex-0.4:=
+ dev-ml/camlzip:=
+ dev-ml/cmdliner:=
+ dev-ml/num:=
+ dev-ml/seq:=
+ dev-ml/stdlib-shims:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/dune-configurator"
+
+src_prepare() {
+ default
+
+ # Remove the GTK2 GUI frontend because GTK2 in Gentoo is deprecated
+ rm -r src/bin/gui || die
+}
+
+src_configure() {
+ sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ dune-install alt-ergo-lib alt-ergo-parsers alt-ergo
+
+ use examples && dodoc -r examples
+}