summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-11 04:09:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-11 04:44:07 +0100
commitae18040bc339f7813cdf0372ad0afde8534ecdd1 (patch)
tree0cccf0cfd58755d41c4577a5b61584745c86cafb /sci-mathematics/cadical/cadical-1.5.3-r1.ebuild
parentsci-mathematics/btor2tools: new package; add 1.0.0_pre20220518 (diff)
downloadgentoo-ae18040bc339f7813cdf0372ad0afde8534ecdd1.tar.gz
gentoo-ae18040bc339f7813cdf0372ad0afde8534ecdd1.tar.bz2
gentoo-ae18040bc339f7813cdf0372ad0afde8534ecdd1.zip
sci-mathematics/cadical: install ccadical.h
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/cadical/cadical-1.5.3-r1.ebuild')
-rw-r--r--sci-mathematics/cadical/cadical-1.5.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/cadical-1.5.3-r1.ebuild b/sci-mathematics/cadical/cadical-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..63bd3bf453f3
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-1.5.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/"
+SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-rel-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
+ "${FILESDIR}"/${PN}-makefile.in-ar.patch
+)
+
+DOCS=( BUILD.md CONTRIBUTING NEWS.md README.md VERSION )
+
+src_configure() {
+ tc-export AR
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+ einstalldocs
+}