summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-21 03:41:21 +0000
committerSam James <sam@gentoo.org>2021-02-21 03:41:21 +0000
commit31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4 (patch)
tree1fc7de1c8fbc690b972ad97f58f92fc4aaf1bf5a /sci-mathematics/euler/euler-1.61.0-r1.ebuild
parentsys-process/parallel: Stabilize 20210122 arm, #771807 (diff)
downloadgentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.tar.gz
gentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.tar.bz2
gentoo-31cb4a3e3f5d166a4682f47aad7d2f6517b7b0e4.zip
sci-mathematics/euler: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics/euler/euler-1.61.0-r1.ebuild')
-rw-r--r--sci-mathematics/euler/euler-1.61.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/euler/euler-1.61.0-r1.ebuild b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
new file mode 100644
index 000000000000..b54a13030b48
--- /dev/null
+++ b/sci-mathematics/euler/euler-1.61.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mathematical programming environment"
+HOMEPAGE="http://euler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/euler/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="
+ ${DEPEND}
+ x11-misc/xdg-utils
+"
+
+PATCHES=(
+ "${FILESDIR}"/configure-gentoo.patch
+ "${FILESDIR}"/command-gcc4-gentoo.patch
+ "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
+ "${FILESDIR}"/${PN}-xdg.patch
+ "${FILESDIR}"/${PN}-fortify.patch
+)
+
+src_prepare() {
+ default
+
+ # gentoo specific stuff
+ sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
+ sed -i \
+ -e "s:doc/euler:doc/${PF}:g" \
+ Makefile.am docs/Makefile.am \
+ docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
+ || die "sed for docs failed"
+
+ eautoreconf
+}