summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-02 23:42:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-02 23:42:18 +0200
commit56a7877fca5ed96053d93689e4e4a28786f3003f (patch)
tree9ad37859e3d2aee6404f9f0f3a59adaae5e36d3d /sci-mathematics/lean
parentdev-lang/go: unkeyword 1.19 (diff)
downloadgentoo-56a7877fca5ed96053d93689e4e4a28786f3003f.tar.gz
gentoo-56a7877fca5ed96053d93689e4e4a28786f3003f.tar.bz2
gentoo-56a7877fca5ed96053d93689e4e4a28786f3003f.zip
sci-mathematics/lean: filter LTO (odr)
Closes: https://bugs.gentoo.org/863086 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/lean')
-rw-r--r--sci-mathematics/lean/lean-3.43.0.ebuild4
-rw-r--r--sci-mathematics/lean/lean-3.44.1.ebuild4
-rw-r--r--sci-mathematics/lean/lean-3.45.0.ebuild4
-rw-r--r--sci-mathematics/lean/lean-3.9999.ebuild4
4 files changed, 12 insertions, 4 deletions
diff --git a/sci-mathematics/lean/lean-3.43.0.ebuild b/sci-mathematics/lean/lean-3.43.0.ebuild
index 5d8ee8eecd4b..6623228581a0 100644
--- a/sci-mathematics/lean/lean-3.43.0.ebuild
+++ b/sci-mathematics/lean/lean-3.43.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MAJOR=$(ver_cut 1)
CMAKE_IN_SOURCE_BUILD="ON"
-inherit cmake readme.gentoo-r1
+inherit flag-o-matic cmake readme.gentoo-r1
DESCRIPTION="The Lean Theorem Prover"
HOMEPAGE="https://leanprover-community.github.io/"
@@ -37,6 +37,8 @@ src_configure() {
CMAKE_BUILD_TYPE="Release"
fi
+ filter-lto
+
local mycmakeargs=(
-DALPHA=ON
-DAUTO_THREAD_FINALIZATION=ON
diff --git a/sci-mathematics/lean/lean-3.44.1.ebuild b/sci-mathematics/lean/lean-3.44.1.ebuild
index 5d8ee8eecd4b..6623228581a0 100644
--- a/sci-mathematics/lean/lean-3.44.1.ebuild
+++ b/sci-mathematics/lean/lean-3.44.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MAJOR=$(ver_cut 1)
CMAKE_IN_SOURCE_BUILD="ON"
-inherit cmake readme.gentoo-r1
+inherit flag-o-matic cmake readme.gentoo-r1
DESCRIPTION="The Lean Theorem Prover"
HOMEPAGE="https://leanprover-community.github.io/"
@@ -37,6 +37,8 @@ src_configure() {
CMAKE_BUILD_TYPE="Release"
fi
+ filter-lto
+
local mycmakeargs=(
-DALPHA=ON
-DAUTO_THREAD_FINALIZATION=ON
diff --git a/sci-mathematics/lean/lean-3.45.0.ebuild b/sci-mathematics/lean/lean-3.45.0.ebuild
index 5d8ee8eecd4b..6623228581a0 100644
--- a/sci-mathematics/lean/lean-3.45.0.ebuild
+++ b/sci-mathematics/lean/lean-3.45.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MAJOR=$(ver_cut 1)
CMAKE_IN_SOURCE_BUILD="ON"
-inherit cmake readme.gentoo-r1
+inherit flag-o-matic cmake readme.gentoo-r1
DESCRIPTION="The Lean Theorem Prover"
HOMEPAGE="https://leanprover-community.github.io/"
@@ -37,6 +37,8 @@ src_configure() {
CMAKE_BUILD_TYPE="Release"
fi
+ filter-lto
+
local mycmakeargs=(
-DALPHA=ON
-DAUTO_THREAD_FINALIZATION=ON
diff --git a/sci-mathematics/lean/lean-3.9999.ebuild b/sci-mathematics/lean/lean-3.9999.ebuild
index 5d8ee8eecd4b..6623228581a0 100644
--- a/sci-mathematics/lean/lean-3.9999.ebuild
+++ b/sci-mathematics/lean/lean-3.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MAJOR=$(ver_cut 1)
CMAKE_IN_SOURCE_BUILD="ON"
-inherit cmake readme.gentoo-r1
+inherit flag-o-matic cmake readme.gentoo-r1
DESCRIPTION="The Lean Theorem Prover"
HOMEPAGE="https://leanprover-community.github.io/"
@@ -37,6 +37,8 @@ src_configure() {
CMAKE_BUILD_TYPE="Release"
fi
+ filter-lto
+
local mycmakeargs=(
-DALPHA=ON
-DAUTO_THREAD_FINALIZATION=ON