summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-19 19:41:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-19 23:28:15 +0100
commitd5a1050d3e2e050151e73d63d624a2aeafeba061 (patch)
treee40ec63015ee33ae51395357405d9bf0672b750d /sci-mathematics/libpoly/libpoly-0.1.11.ebuild
parentapp-emacs/orderless: bump to 0.8 (diff)
downloadgentoo-d5a1050d3e2e050151e73d63d624a2aeafeba061.tar.gz
gentoo-d5a1050d3e2e050151e73d63d624a2aeafeba061.tar.bz2
gentoo-d5a1050d3e2e050151e73d63d624a2aeafeba061.zip
sci-mathematics/libpoly: remove -Werror
Closes: https://bugs.gentoo.org/887109 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/libpoly/libpoly-0.1.11.ebuild')
-rw-r--r--sci-mathematics/libpoly/libpoly-0.1.11.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sci-mathematics/libpoly/libpoly-0.1.11.ebuild b/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
index e3b8fb247367..09b57d07fe96 100644
--- a/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
+++ b/sci-mathematics/libpoly/libpoly-0.1.11.ebuild
@@ -34,6 +34,14 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ sed -i "s| -Werror||g" \
+ "${S}"/src/CMakeLists.txt \
+ "${S}"/test/polyxx/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DLIBPOLY_BUILD_PYTHON_API=$(usex python)