summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 04:03:17 +0000
committerSam James <sam@gentoo.org>2021-01-17 04:10:28 +0000
commit13795972d83aa1591561d7e60c220c623538b5e2 (patch)
treead847f032f1eed0478f66bbccf210f6240b518f8 /sci-mathematics/why3-for-spark
parentsci-mathematics/why3-for-spark: supports both lablgtk:2, :3 for most versions (diff)
downloadgentoo-13795972d83aa1591561d7e60c220c623538b5e2.tar.gz
gentoo-13795972d83aa1591561d7e60c220c623538b5e2.tar.bz2
gentoo-13795972d83aa1591561d7e60c220c623538b5e2.zip
sci-mathematics/why3-for-spark: update OCaml deps
* We need := for OCaml deps to ensure we're rebuilt when they update for consistency, to prevent strange issues. * Use ocamlopt= rather than ocamlopt? in the dev-lang/ocaml dependency to ensure ocamlopt is consistently on/off throughout the system. Package-Manager: Portage-3.0.12.0.2-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics/why3-for-spark')
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild16
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2019-r1.ebuild14
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2019-r2.ebuild16
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild14
4 files changed, 30 insertions, 30 deletions
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
index 6314df13e4bb..bb7093a5b79d 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
@@ -16,18 +16,18 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64"
IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
-RESTRICT=strip
+RESTRICT="strip"
-DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
- dev-ml/menhir
+DEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt=]
+ dev-ml/menhir:=
coq? ( sci-mathematics/coq )
doc? ( dev-tex/rubber )
- gtk? ( dev-ml/lablgtk:2[sourceview] )
+ gtk? ( dev-ml/lablgtk:2=[sourceview] )
emacs? ( >=app-editors/emacs-23.1:* )
- html? ( dev-tex/hevea )
- hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )
- zip? ( >=dev-ml/camlzip-1.07 )"
+ html? ( dev-tex/hevea:= )
+ hypothesis-selection? ( dev-ml/ocamlgraph:= )
+ zarith? ( dev-ml/zarith:= )
+ zip? ( >=dev-ml/camlzip-1.07:= )"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MYP}
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2019-r1.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2019-r1.ebuild
index 4ff38ed03305..e4953adc3ce0 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2019-r1.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2019-r1.ebuild
@@ -18,18 +18,18 @@ KEYWORDS="~amd64"
IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt zarith zip"
RESTRICT=strip
-DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-4.09.0:=[ocamlopt=]
>=dev-ml/ocamlbuild-0.14.0
- dev-ml/menhir
- dev-ml/num
+ dev-ml/menhir:=
+ dev-ml/num:=
coq? ( >=sci-mathematics/coq-8.9.1 )
doc? ( dev-tex/rubber )
gtk? ( >=dev-ml/lablgtk-2.18.8:=[sourceview] )
emacs? ( >=app-editors/emacs-23.1:* )
- html? ( dev-tex/hevea )
- hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )
- zip? ( >=dev-ml/camlzip-1.07 )"
+ html? ( dev-tex/hevea:= )
+ hypothesis-selection? ( dev-ml/ocamlgraph:= )
+ zarith? ( dev-ml/zarith:= )
+ zip? ( >=dev-ml/camlzip-1.07:= )"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MYP}
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2019-r2.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2019-r2.ebuild
index 738641a23753..9fa713b6baaa 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2019-r2.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2019-r2.ebuild
@@ -14,20 +14,20 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt zarith zip"
-RESTRICT=strip
+RESTRICT="strip"
-DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-4.09.0:=[ocamlopt=]
>=dev-ml/ocamlbuild-0.14.0
- dev-ml/menhir
- dev-ml/num
+ dev-ml/menhir:=
+ dev-ml/num:=
coq? ( >=sci-mathematics/coq-8.9.1 )
doc? ( dev-tex/rubber )
gtk? ( >=dev-ml/lablgtk-2.18.8:=[sourceview] )
emacs? ( >=app-editors/emacs-23.1:* )
- html? ( dev-tex/hevea )
- hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )
- zip? ( >=dev-ml/camlzip-1.07 )"
+ html? ( dev-tex/hevea:= )
+ hypothesis-selection? ( dev-ml/ocamlgraph:= )
+ zarith? ( dev-ml/zarith:= )
+ zip? ( >=dev-ml/camlzip-1.07:= )"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MYP}
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild
index 5ad16322b0a7..72c43f3fc8c4 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2019.ebuild
@@ -16,18 +16,18 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
-RESTRICT=strip
+RESTRICT="strip"
-DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
- dev-ml/menhir
+DEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt=]
+ dev-ml/menhir:=
coq? ( sci-mathematics/coq )
doc? ( dev-tex/rubber )
gtk? ( dev-ml/lablgtk:=[sourceview] )
emacs? ( >=app-editors/emacs-23.1:* )
- html? ( dev-tex/hevea )
- hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )
- zip? ( >=dev-ml/camlzip-1.07 )"
+ html? ( dev-tex/hevea:= )
+ hypothesis-selection? ( dev-ml/ocamlgraph:= )
+ zarith? ( dev-ml/zarith:= )
+ zip? ( >=dev-ml/camlzip-1.07:= )"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MYP}