summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-05-07 13:54:22 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-05-07 13:59:02 -0500
commit456764076a13b6be867dfd94536a73118fd9fd89 (patch)
tree1f7edee0ab9d874ad3aec4d2d8ed0312da302554 /sci-mathematics
parentsci-mathematics/slepc: add 3.19.0 (diff)
downloadgentoo-456764076a13b6be867dfd94536a73118fd9fd89.tar.gz
gentoo-456764076a13b6be867dfd94536a73118fd9fd89.tar.bz2
gentoo-456764076a13b6be867dfd94536a73118fd9fd89.zip
sci-mathematics/slepc: update SRC_URI and fix USE=doc
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/slepc/Manifest1
-rw-r--r--sci-mathematics/slepc/slepc-3.19.0.ebuild9
2 files changed, 9 insertions, 1 deletions
diff --git a/sci-mathematics/slepc/Manifest b/sci-mathematics/slepc/Manifest
index 62251e13d86d..989e43b029f9 100644
--- a/sci-mathematics/slepc/Manifest
+++ b/sci-mathematics/slepc/Manifest
@@ -2,3 +2,4 @@ DIST slepc-3.16.0.tar.gz 5486237 BLAKE2B 28f45036ba7e6aa2b227c6f25e2c8edf7fc6914
DIST slepc-3.17.1.tar.gz 5450177 BLAKE2B ec4f597085a176a010797d599779cc4532e52996105bb76f755073876ebb81026c580cb5759a03bda58cb2de2767b1dcdb01ff0d946f218117edb2a7a6557414 SHA512 5429aa7516ec0b2fee8158f9317634faf1c963aa60237be81a0392d5f2fa9f531db59b4a9ad04e266d808befdbd71b5a30259b4abc639a1da2defffd74acd35b
DIST slepc-3.18.1.tar.gz 6013016 BLAKE2B 1526b7e6e0f0387a8410cfcbee9bc62f35f930420b86bcb58146b16f73b28b349c6aad0ef59e02a635c374a0a8b6eb16ac50b7bcb79ce6c06a3de56029db551a SHA512 d366844c492be6bf77edabdbe0d61672ead45605fc299c25ac24bf14d9d15bc107bb62f0d08aa403a5f269a2b12ae4d7cd3768958d792812e6c1924b93a27be4
DIST slepc-3.19.0.tar.gz 1803822 BLAKE2B 742cc773e649d46ff8513263ef53fe5d62f6cac537d5444eeeb494d0816d496a5c0c2f260615aa8a82ebdc983877302acf7d0c88f01bd4bea66246149dabac13 SHA512 edb8c589c162766a7b4a81b484356f2a5b2f70a7c90c87e39efda1a00f6fe544d7ae644e8903059b7dab990c1fa2129cd5d1c7dbb759511483ab43d3d691419c
+DIST slepc-with-docs-3.19.0.tar.gz 6320650 BLAKE2B 32d383d7ddfe6cf21755fcae768517830076d38ef4c0d844c0a4270194de541a32849883d951f1a47d98491be05866b415de3ca6148b9d9cdf0bfc5e6487234e SHA512 48695c8449a323755a5d8bd3e88560e72ef82a48d0d1150e2a751a323db02836b76666bbaea3bb44c9a79b900a93337f6ced12aba6cfd939a7c1edae49f17e71
diff --git a/sci-mathematics/slepc/slepc-3.19.0.ebuild b/sci-mathematics/slepc/slepc-3.19.0.ebuild
index dacebd229f02..3622655a7bd1 100644
--- a/sci-mathematics/slepc/slepc-3.19.0.ebuild
+++ b/sci-mathematics/slepc/slepc-3.19.0.ebuild
@@ -9,7 +9,9 @@ inherit python-any-r1
DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
HOMEPAGE="https://slepc.upv.es/"
-SRC_URI="https://slepc.upv.es/download/distrib/${P}.tar.gz"
+SRC_URI="
+ !doc? ( https://slepc.upv.es/download/distrib/${P}.tar.gz )
+ doc? ( https://slepc.upv.es/download/distrib/${PN}-with-docs-${PV}.tar.gz )"
LICENSE="LGPL-3"
SLOT="0"
@@ -32,6 +34,11 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} V=1"
+src_unpack() {
+ use doc || unpack ${P}.tar.gz
+ use doc && unpack ${PN}-with-docs-${PV}.tar.gz
+}
+
src_configure() {
# *sigh*
addpredict "${PETSC_DIR}"/.nagged