summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-06-27 15:41:19 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-06-27 15:41:44 +0200
commit8de4f2b8e051029312a51f9a1beb4f527e8cbb0a (patch)
tree019bfc1902288d5b9b7f8835a17a62ff318d35a7 /sci-physics/clhep/clhep-2.4.1.2.ebuild
parentsys-boot/os-prober: Removed superfluous "local dir" statement (diff)
downloadgentoo-8de4f2b8e051029312a51f9a1beb4f527e8cbb0a.tar.gz
gentoo-8de4f2b8e051029312a51f9a1beb4f527e8cbb0a.tar.bz2
gentoo-8de4f2b8e051029312a51f9a1beb4f527e8cbb0a.zip
sci-physics/clhep: version bump to 2.4.1.2
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/clhep/clhep-2.4.1.2.ebuild')
-rw-r--r--sci-physics/clhep/clhep-2.4.1.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-physics/clhep/clhep-2.4.1.2.ebuild b/sci-physics/clhep/clhep-2.4.1.2.ebuild
new file mode 100644
index 000000000000..8eac6ef22dd0
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.4.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://proj-clhep.web.cern.ch/proj-clhep/"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/dist1/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+IUSE="doc test threads"
+
+BDEPEND="doc? ( app-doc/doxygen[latex] )"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # dont build test if not asked
+ if ! use test; then
+ sed -i \
+ -e '/add_subdirectory(test)/d' \
+ */CMakeLists.txt || die
+ fi
+ # gentoo doc directory
+ if use doc; then
+ grep -rl 'share/doc/CLHEP' |
+ xargs sed -i \
+ -e "s:share/doc/CLHEP:share/doc/${PF}:" \
+ {.,*}/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_BUILD_DOCS=$(usex doc)
+ -DCLHEP_SINGLE_THREAD=$(usex threads no yes)
+ )
+ DESTDIR="${ED}" cmake-utils_src_configure
+}