summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-28 23:38:27 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-29 00:57:49 +0100
commite35be1e09b3a2ba56032763c01116bb1c5e75ab0 (patch)
treea3352102acfb7e37aae1085c44552b7a1f15a036 /sys-apps/baobab/baobab-3.30.0.ebuild
parentdev-libs/libressl: stable 2.6.5 for hppa, bug #658158 (diff)
downloadgentoo-e35be1e09b3a2ba56032763c01116bb1c5e75ab0.tar.gz
gentoo-e35be1e09b3a2ba56032763c01116bb1c5e75ab0.tar.bz2
gentoo-e35be1e09b3a2ba56032763c01116bb1c5e75ab0.zip
sys-apps/baobab: 3.26.1 → 3.30.0
Switch build system to meson. Drop gsettings-desktop-schemas as it is unused. adwaita-icon-theme is pulled by gtk+:3. Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'sys-apps/baobab/baobab-3.30.0.ebuild')
-rw-r--r--sys-apps/baobab/baobab-3.30.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/baobab/baobab-3.30.0.ebuild b/sys-apps/baobab/baobab-3.30.0.ebuild
new file mode 100644
index 000000000000..345ffcca3795
--- /dev/null
+++ b/sys-apps/baobab/baobab-3.30.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Disk usage browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_icon_cache_update
+}