summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-04 00:35:19 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-04 00:36:48 -0600
commit64d0ddf64fc6ec5cb3168dff14ab5259ae2e9206 (patch)
tree615e4ab2025a9d7b6a0e9ac5593df1f40564a2c4 /sys-apps/baselayout/baselayout-9999.ebuild
parentdev-python/jupyterlab: Keyword 3.5.2 x86, #887521 (diff)
downloadgentoo-64d0ddf64fc6ec5cb3168dff14ab5259ae2e9206.tar.gz
gentoo-64d0ddf64fc6ec5cb3168dff14ab5259ae2e9206.tar.bz2
gentoo-64d0ddf64fc6ec5cb3168dff14ab5259ae2e9206.zip
sys-apps/baselayout: add back the case statement
We may only need to do this on the specific hosts listed. More research needs to be done before I can remove the case statement. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps/baselayout/baselayout-9999.ebuild')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index 6a97e21522d9..35af87850d7c 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -163,13 +163,17 @@ multilib_layout() {
# make sure the old "lib" ABI location does not exist; we
# only symlinked the lib dir on systems where we moved it
# to "lib32" ...
- if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
- rm -f "${prefix}lib32"/.keep || die
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
+ case ${CHOST} in
+ i?86*|x86_64*|powerpc*|sparc*|s390*)
+ if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
+ rm -f "${prefix}lib32"/.keep || die
+ if ! rmdir "${prefix}lib32" 2>/dev/null ; then
+ ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
+ die "non-empty dir found where there should be none: ${prefix}lib32"
+ fi
fi
- fi
+ ;;
+ esac
else
# nothing exists, so just set it up sanely
ewarn "Initializing ${prefix}lib as a dir"