summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-24 13:13:58 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-24 13:14:17 -0500
commit6a81aeec42f39c638dfb4ca88d97b8d9d2d01eb2 (patch)
tree36f41bdd2d87fc99b7633ab19e1c5e8fc7c8a330 /sys-apps/bolt
parentsys-apps/bolt: add openrc support (diff)
downloadgentoo-6a81aeec42f39c638dfb4ca88d97b8d9d2d01eb2.tar.gz
gentoo-6a81aeec42f39c638dfb4ca88d97b8d9d2d01eb2.tar.bz2
gentoo-6a81aeec42f39c638dfb4ca88d97b8d9d2d01eb2.zip
sys-apps/bolt: bump
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/Manifest2
-rw-r--r--sys-apps/bolt/bolt-0.8-r1.ebuild46
-rw-r--r--sys-apps/bolt/bolt-0.9.ebuild41
3 files changed, 0 insertions, 89 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 1f4de624160f..41dbe3bd2d07 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1,3 +1 @@
-DIST bolt-0.8.tar.gz 219317 BLAKE2B 9d76f3630d7f690c96447a894e54095deb7a19e46f2b02d7fbd9e584376d6b1a19391007a3a80e293adc8c9de6470279b587807d08006bbc12c7179bf0501e40 SHA512 0fdbc026178a4ca6a8c53aa46933d1c411eb04e350955f8b10c7faff814576d0796dd28e56b968648e549c79cf5fa13d43970d797595af0f66457abaef8ace09
DIST bolt-0.9.tar.gz 238596 BLAKE2B 8032ecb83d39d6c3550c000eed400ee0451e5ed94f7c898ffe9c8fcf512af387cfd759bd94241a47623b5aac63615bcda40ddb3e9ae3ec4060da20e46d7e9b7d SHA512 427e9ad95a8d018dd22326cc4b458fc9149b001d3aa6e4bb8e4047eaf6c3cf04a4dc3be9396049734dc0bd54f990b3bce31b6eef4031e3b671a6202a588cfe78
-DIST bolt-210-r2.patch 369 BLAKE2B 2ee8b084d8a89fac361e434fddaac50a1c10fd412b450dbe496d263d07cbd9961c33b84b04ae8296154ad16c01f6c3ba6599b48649d54c4ceb77d52797eddb53 SHA512 e66787ab18acb9924903ab92bf878e48b4aed39ea6aa18d874121316cb0452a00358a4adde1e7bbd903d682a6a001e20fd573af782db25d6c54b18ffafd29329
diff --git a/sys-apps/bolt/bolt-0.8-r1.ebuild b/sys-apps/bolt/bolt-0.8-r1.ebuild
deleted file mode 100644
index 83ece17b667f..000000000000
--- a/sys-apps/bolt/bolt-0.8-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit meson systemd
-
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
-HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz
- https://gitlab.freedesktop.org/bolt/bolt/-/commit/5a739574608e5190816b3efd22e75f214c5fe4c4.diff -> ${PN}-210-r2.patch"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc systemd"
-
-DEPEND="
- >=dev-libs/glib-2.50.0:2
- dev-util/glib-utils
- virtual/libudev
- virtual/udev
- dev-util/umockdev
- sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${DISTDIR}/${PN}-210-r2.patch"
-)
-
-src_configure() {
- local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- keepdir /var/lib/boltd
-}
diff --git a/sys-apps/bolt/bolt-0.9.ebuild b/sys-apps/bolt/bolt-0.9.ebuild
deleted file mode 100644
index f9decd2321f0..000000000000
--- a/sys-apps/bolt/bolt-0.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit meson systemd
-
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
-HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc systemd"
-
-DEPEND="
- >=dev-libs/glib-2.56.0:2
- dev-util/glib-utils
- virtual/libudev
- virtual/udev
- dev-util/umockdev
- sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- keepdir /var/lib/boltd
-}