summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-01 14:45:12 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-01 14:45:12 +0100
commit7284863d8d2b1d207d01741475e134284e4e6f9f (patch)
treed97990b3cb267e64d44d514781a588890dba8035 /sys-apps/etckeeper/etckeeper-1.18.6.ebuild
parentdev-python/prometheus_client: Version bump to 0.0.19 (diff)
downloadgentoo-7284863d8d2b1d207d01741475e134284e4e6f9f.tar.gz
gentoo-7284863d8d2b1d207d01741475e134284e4e6f9f.tar.bz2
gentoo-7284863d8d2b1d207d01741475e134284e4e6f9f.zip
sys-apps/etckeeper: Version bump to 1.18.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/etckeeper/etckeeper-1.18.6.ebuild')
-rw-r--r--sys-apps/etckeeper/etckeeper-1.18.6.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/etckeeper/etckeeper-1.18.6.ebuild b/sys-apps/etckeeper/etckeeper-1.18.6.ebuild
new file mode 100644
index 000000000000..245afd7e0e47
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.18.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="https://etckeeper.branchable.com/"
+SRC_URI="https://github.com/joeyh/etckeeper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="bazaar cron"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ ${PYTHON} ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ dodoc doc/README.mdwn
+ docinto examples
+ newdoc "${FILESDIR}"/bashrc-r1 bashrc
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${PF}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}