summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-24 10:55:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-24 10:58:02 +0200
commit6d0b89f14127625f091fe9edbec9ca41ac1accd2 (patch)
treef3701306596985366d00325f8c77e82b425c3f04 /sys-apps/file
parentnet-analyzer/wireshark: Old. (diff)
downloadgentoo-6d0b89f14127625f091fe9edbec9ca41ac1accd2.tar.gz
gentoo-6d0b89f14127625f091fe9edbec9ca41ac1accd2.tar.bz2
gentoo-6d0b89f14127625f091fe9edbec9ca41ac1accd2.zip
sys-apps/file: Revbump to fix berkdb file magic
Bumped straight to stable Closes: https://bugs.gentoo.org/661922 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-5.33-r4.ebuild (renamed from sys-apps/file/file-5.33-r3.ebuild)5
-rw-r--r--sys-apps/file/files/file-5.33-berkdb_bogus_magic.patch33
2 files changed, 36 insertions, 2 deletions
diff --git a/sys-apps/file/file-5.33-r3.ebuild b/sys-apps/file/file-5.33-r4.ebuild
index e9203f385ff5..1221edeea29a 100644
--- a/sys-apps/file/file-5.33-r3.ebuild
+++ b/sys-apps/file/file-5.33-r4.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
DISTUTILS_OPTIONAL=1
-inherit distutils-r1 libtool ltprune toolchain-funcs multilib-minimal
+inherit distutils-r1 libtool toolchain-funcs multilib-minimal
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/glensc/file.git"
@@ -36,6 +36,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-CVE-2018-10360.patch
"${FILESDIR}"/${P}-gl_VISIBILITY-macro.patch
+ "${FILESDIR}"/${P}-berkdb_bogus_magic.patch #661922
)
src_prepare() {
@@ -129,5 +130,5 @@ multilib_src_install_all() {
cd python || die
distutils-r1_src_install
fi
- prune_libtool_files
+ find "${ED}" -name "*.la" -delete || die
}
diff --git a/sys-apps/file/files/file-5.33-berkdb_bogus_magic.patch b/sys-apps/file/files/file-5.33-berkdb_bogus_magic.patch
new file mode 100644
index 000000000000..7627bafc6ef9
--- /dev/null
+++ b/sys-apps/file/files/file-5.33-berkdb_bogus_magic.patch
@@ -0,0 +1,33 @@
+From 4fb6a59df80d4974f8230bfce36e38e6de7d574f Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Thu, 24 May 2018 18:54:40 +0000
+Subject: [PATCH] fix bogus magic
+
+---
+ magic/Magdir/dbpf | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/magic/Magdir/dbpf b/magic/Magdir/dbpf
+index 65cab61e..8545720d 100644
+--- a/magic/Magdir/dbpf
++++ b/magic/Magdir/dbpf
+@@ -1,6 +1,6 @@
+
+ #------------------------------------------------------------------------------
+-# $File: dbpf,v 1.1 2017/10/13 20:47:14 christos Exp $
++# $File: dbpf,v 1.2 2018/05/24 18:54:40 christos Exp $
+ # dppf: Maxis Database Packed Files, the stored data file format used by all
+ # Maxis games after the Sims: http://wiki.niotso.org/DBPF
+ # http://www.wiki.sc4devotion.com/index.php?title=DBPF
+@@ -9,9 +9,7 @@
+ >4 ulelong x \b, version: %u.
+ >>8 ulelong x \b%u
+ >>>36 ulelong x \b, files: %u
++>>24 ledate !0 \b, created: %s
++>>28 ledate !0 \b, modified: %s
+ !:ext dbpf/package/dat/sc4
+ !:mime application/x-maxis-dbpf
+-4 ulelong 1
+->8 ulelong !1
+->>24 ledate !0 \b, created: %s
+->>>28 ledate !0 \b, modified: %s