summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-26 12:05:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-26 12:05:03 +0100
commit558ee546f2af179b5b3a36480789435a82afe96f (patch)
tree2f6b9e04f18e35037d96f75b12710a9fc55c8aed /sys-apps/habitat/habitat-0.54.0.ebuild
parentsys-apps/gawk: Bump to version 4.2.1 (diff)
downloadgentoo-558ee546f2af179b5b3a36480789435a82afe96f.tar.gz
gentoo-558ee546f2af179b5b3a36480789435a82afe96f.tar.bz2
gentoo-558ee546f2af179b5b3a36480789435a82afe96f.zip
sys-apps/habitat: Version bump to 0.54.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/habitat/habitat-0.54.0.ebuild')
-rw-r--r--sys-apps/habitat/habitat-0.54.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/habitat/habitat-0.54.0.ebuild b/sys-apps/habitat/habitat-0.54.0.ebuild
new file mode 100644
index 000000000000..407816389d25
--- /dev/null
+++ b/sys-apps/habitat/habitat-0.54.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Application automation framework"
+HOMEPAGE="https://github.com/habitat-sh/habitat https://habitat.sh"
+SRC_URI="https://github.com/habitat-sh/habitat/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mrueg/files/${PN}-cargo-${PV}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-util/cargo
+ >=virtual/rust-1.23
+ >=net-libs/zeromq-3.2
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # move cache dir where cargo expects it
+ mv ../.cargo "${HOME}" || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin target/debug/hab{,-butterfly,-sup}
+}
+
+src_test() {
+ emake unit-all
+}