summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-13 13:56:11 +0000
committerSam James <sam@gentoo.org>2024-12-13 13:57:42 +0000
commitca26b31b9e6ce2ab2dd51ed422f2e976dece5aea (patch)
tree688c65d570ff10ac80ca74889ce03efe1518ece1 /sys-apps/kbd
parentsys-apps/moreutils: add 0.70 (diff)
downloadgentoo-ca26b31b9e6ce2ab2dd51ed422f2e976dece5aea.tar.gz
gentoo-ca26b31b9e6ce2ab2dd51ed422f2e976dece5aea.tar.bz2
gentoo-ca26b31b9e6ce2ab2dd51ed422f2e976dece5aea.zip
sys-apps/kbd: add 2.7
Drop the maintainer mode workaround as Eli's fixes to Portage's regex mean it is no longer flagged. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.7.ebuild84
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild8
3 files changed, 85 insertions, 8 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 8203afcb6248..a187b18dc8fb 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1,2 +1,3 @@
DIST kbd-2.5.1.tar.xz 1491952 BLAKE2B aab4c3d78c28709bf562b54fe94c0533d5c33185e183bf3eb944f89147b250d9df9b30b64a06eb4742feafe8c05a6aa491a7f007b4d6d9077bc19a4628ba05ae SHA512 74855f486aff5fc2f93a6cb29460a590c94eac653b001574e1b4eb1300ea99dfed9222f9e5d1d3a05a112a6880591d5c44ed6e76b8a64edf744ecb0892f562d0
DIST kbd-2.6.4.tar.xz 1504584 BLAKE2B 25e55be0210c206c1f5eb0d85045bb1cbb2442cf88fb7eb28f7bbb8dd0d86473f48444fd9d80dfc624ce7ba8b39bfe1152ee6cf1877fab444e09600e93dae0ee SHA512 a4149cb0f85fd79b333a6c137d70896a30ebceb1cf9d4b5eef3abb2e1866d83b46cee651e4f3e512bf7e0ccd232d955c14f693e57020a3626e4943c4695fc8ab
+DIST kbd-2.7.tar.xz 1470532 BLAKE2B 0222a4566ad0bd91629e5d8a7bf8ca14e82cde933b0892bf63740ccd7aae89ff5130f228a7b4cad7e88c42562320400f4238212274f90233c73f0419ac81a696 SHA512 22c7eca0e23a6df22218ecb4f3e9e50a58a3d56d951cdd7284cf0ac426d789b547cc55b1293b4aff3fc64c2a148b1733c09d8865ae46fbc617f0b0fa64c44436
diff --git a/sys-apps/kbd/kbd-2.7.ebuild b/sys-apps/kbd/kbd-2.7.ebuild
new file mode 100644
index 000000000000..8031a4293998
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="https://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls selinux pam test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-alternatives/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-loadkeys )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ default
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ # See also https://github.com/legionus/kbd/issues/76.
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
+
+ if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake -Onone check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}
+
+src_install() {
+ default
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index ca0b13cdd97e..8031a4293998 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -27,11 +27,6 @@ SLOT="0"
IUSE="nls selinux pam test"
RESTRICT="!test? ( test )"
-# Testsuite's Makefile.am calls missing(!)
-# ... but this seems to be consistent with the autoconf docs?
-# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
-QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
-
DEPEND="
app-alternatives/gzip
pam? (
@@ -84,9 +79,6 @@ src_test() {
src_install() {
default
- docinto html
- dodoc docs/doc/*.html
-
# USE="test" installs .la files
find "${ED}" -type f -name "*.la" -delete || die
}