summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-18 00:57:15 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-18 01:20:08 +0200
commit1e08fab5abc3a1f22f9acc4cbb1061daefa90891 (patch)
tree383d9c0850f8438c1e96dea23ae8ceddb8b7a0f2 /sys-apps/memtester/memtester-4.5.1.ebuild
parentnet-print/hplip-plugin: Version bump to 3.21.4 (diff)
downloadgentoo-1e08fab5abc3a1f22f9acc4cbb1061daefa90891.tar.gz
gentoo-1e08fab5abc3a1f22f9acc4cbb1061daefa90891.tar.bz2
gentoo-1e08fab5abc3a1f22f9acc4cbb1061daefa90891.zip
sys-apps/memtester: bump to v4.5.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/memtester/memtester-4.5.1.ebuild')
-rw-r--r--sys-apps/memtester/memtester-4.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/memtester/memtester-4.5.1.ebuild b/sys-apps/memtester/memtester-4.5.1.ebuild
new file mode 100644
index 000000000000..2084213eb705
--- /dev/null
+++ b/sys-apps/memtester/memtester-4.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="userspace utility for testing the memory subsystem for faults"
+HOMEPAGE="http://pyropus.ca/software/memtester/"
+SRC_URI="
+ http://pyropus.ca/software/memtester/${P}.tar.gz
+ http://pyropus.ca/software/memtester/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dosbin memtester
+ doman memtester.8
+ dodoc BUGS CHANGELOG README README.tests
+}