summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-04 06:30:56 +0100
committerSam James <sam@gentoo.org>2022-05-04 06:31:26 +0100
commit9d496da13dcdd0ac472eb5239185443ae124fb8a (patch)
tree81647bf9a1358e0a5f938f7072979bf9df78387e /sys-apps/smartmontools
parentdev-ruby/itextomml: drop 1.6.0 (diff)
downloadgentoo-9d496da13dcdd0ac472eb5239185443ae124fb8a.tar.gz
gentoo-9d496da13dcdd0ac472eb5239185443ae124fb8a.tar.bz2
gentoo-9d496da13dcdd0ac472eb5239185443ae124fb8a.zip
sys-apps/smartmontools: drop unnecessary eautoreconf
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/smartmontools-7.3.ebuild11
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/sys-apps/smartmontools/smartmontools-7.3.ebuild b/sys-apps/smartmontools/smartmontools-7.3.ebuild
index 121f20999873..777bbd727cb1 100644
--- a/sys-apps/smartmontools/smartmontools-7.3.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.3.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-inherit autotools flag-o-matic systemd
-if [[ ${PV} == "9999" ]] ; then
+inherit flag-o-matic systemd
+if [[ ${PV} == 9999 ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/smartmontools/code/trunk/smartmontools"
ESVN_PROJECT="smartmontools"
- inherit subversion
+ inherit autotools subversion
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
@@ -52,7 +52,10 @@ REQUIRED_USE="(
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
src_configure() {
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 1c0502087af3..2ebbc1a85dc9 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-inherit autotools flag-o-matic systemd
-if [[ ${PV} == "9999" ]] ; then
+inherit flag-o-matic systemd
+if [[ ${PV} == 9999 ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/smartmontools/code/trunk/smartmontools"
ESVN_PROJECT="smartmontools"
- inherit subversion
+ inherit autotools subversion
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
@@ -52,7 +52,10 @@ REQUIRED_USE="(
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
src_configure() {