summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-02-09 14:34:51 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-02-09 14:35:58 +0300
commit3c3d1d71ef1aa4fdbb29f4f4a3035468726f55a6 (patch)
tree2871ec4006fadb5547ed372cd60555469d158d4c /sys-apps
parentdev-ruby/barby: fix slot warning (diff)
downloadgentoo-3c3d1d71ef1aa4fdbb29f4f4a3035468726f55a6.tar.gz
gentoo-3c3d1d71ef1aa4fdbb29f4f4a3035468726f55a6.tar.bz2
gentoo-3c3d1d71ef1aa4fdbb29f4f4a3035468726f55a6.zip
sys-apps/cinit: port to EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cinit/cinit-0.2.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-apps/cinit/cinit-0.2.1.ebuild b/sys-apps/cinit/cinit-0.2.1.ebuild
index c52fcc2f6738..252f62e217b9 100644
--- a/sys-apps/cinit/cinit-0.2.1.ebuild
+++ b/sys-apps/cinit/cinit-0.2.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -17,6 +17,7 @@ IUSE="doc"
src_prepare() {
sed -i "/contrib+tools/d" Makefile || die
sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+ default
}
src_compile() {
@@ -31,7 +32,7 @@ src_compile() {
src_install() {
emake LD=$(tc-getCC) DESTDIR="${D}" install
- rm -f "${D}"/sbin/{init,shutdown,reboot}
+ rm -f "${D}"/sbin/{init,shutdown,reboot} || die
dodoc Changelog CHANGES CREDITS README TODO
use doc && dodoc -r doc
}