summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-14 23:52:30 +0100
committerSam James <sam@gentoo.org>2024-08-14 23:52:59 +0100
commit3e4f940e0fb7ce99c77a64dbb3989312c617b660 (patch)
tree18dfee495dbaa5dd83ffe5f8c73137c7e8ea68fc /sys-apps
parentdev-util/pkgconf: add 2.3.0 (diff)
downloadgentoo-3e4f940e0fb7ce99c77a64dbb3989312c617b660.tar.gz
gentoo-3e4f940e0fb7ce99c77a64dbb3989312c617b660.tar.bz2
gentoo-3e4f940e0fb7ce99c77a64dbb3989312c617b660.zip
sys-apps/ethtool: add 6.10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-6.10.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index 7b21517741c2..00f03ac9bb7b 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,3 +1,4 @@
+DIST ethtool-6.10.tar.xz 360300 BLAKE2B 530ec7fc00a6f88173d403ce0288cbdc7610997feb58bc05b88a87d8606827b8b8e4ce715099f5a6d90257b8e6463ddd259f06f4b0ce9206b2d4742795b86fb1 SHA512 1b6a0f5d2b89de57d1f003779557f2be786e26660ec430e80a966ad047f2fe1fe41bb573738b93454f32cf9089000ae879fc7feba0532bb559636a301ea61b10
DIST ethtool-6.6.tar.xz 352476 BLAKE2B dfbc5f9a6ac63210d1ae305c2458cc44d38d44fcc272c9b0397a13a93e0aa0a09e3750e330a27dcf4dce796c6bd302c4d4c1fd91faab824a81949c31f1ed3504 SHA512 1e7eae3abe59e6af4bce0ebedd0a7ea84d1b0adc7693a0f03021c4096677096a022fdae521ac02413f9db46ee232b89dd2015a116845aa6ca7686fdda50a5b21
DIST ethtool-6.7.tar.xz 352772 BLAKE2B 94a6fd8d29ff479eb894fe56bf991f522fff9af5a94c176d06be2819fe2520125cb48dbded229df1a9f5a0308aeaec503c55caf5d248eef87640c7f90f1132ec SHA512 07d13f9a8f980dab73c07e7c68179cfee272f53103c6dfbce1814b768e3313dc671a0cbefc63d4d53a616876bc1f96db8db2444617e4d58d741fae3acf0be524
DIST ethtool-6.9.tar.xz 358640 BLAKE2B e04fa530084ad14abfea8c3802f272eb61eae9ee07aa2a12d16eeb77708b5ab021f1cdee10c24f83f77d65f2740ba5aceda99c21c47ef6cbcd65834af8334b00 SHA512 bc7e56a1a27a0679119491d6fce076e68374cf47a86fa4c0533851df0aa737cb9139920a9f3f3733deca672923d01bbb579f3d79bd17a2c6738f9f93aa469570
diff --git a/sys-apps/ethtool/ethtool-6.10.ebuild b/sys-apps/ethtool/ethtool-6.10.ebuild
new file mode 100644
index 000000000000..e2e14f39f01b
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}