summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-03 13:41:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-03 13:42:08 +0100
commitce82397ee6f3a3a19c78f58565d48ea90d71550a (patch)
treed5e25bba03f4c7b9bca30373d3e0c3cc0d8b67cb /sys-apps
parentdev-python/wcwidth: s390 stable wrt bug #703062 (diff)
downloadgentoo-ce82397ee6f3a3a19c78f58565d48ea90d71550a.tar.gz
gentoo-ce82397ee6f3a3a19c78f58565d48ea90d71550a.tar.bz2
gentoo-ce82397ee6f3a3a19c78f58565d48ea90d71550a.zip
sys-apps/grep: Bump to version 3.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/grep/Manifest1
-rw-r--r--sys-apps/grep/grep-3.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/grep/Manifest b/sys-apps/grep/Manifest
index ba9d9a9bce99..d33bdf811cb1 100644
--- a/sys-apps/grep/Manifest
+++ b/sys-apps/grep/Manifest
@@ -1,2 +1,3 @@
DIST grep-3.1.tar.xz 1370880 BLAKE2B d71a09d8bfd2c15b6d393d3ca4e22a2b2724632034a6d35d6e269a3c639d76ecaa5ae989a3d8466ee4bcf45e5d08862b0ef19194d6ec7ac6c250e6f60fc61031 SHA512 05494381c7dd8aad7e2ee4c17450de8d7b969a99dcfe17747db60df3475bf02d5323d091e896e8343e4f3251c29dc7f0b7a9f93c575c9d58ee2a57014c2c9d26
DIST grep-3.3.tar.xz 1473056 BLAKE2B e1592b623d1f32d1b21d127b0d28f8f6501d4b854ff2de810d12d43292c00e6af887b038f22d0c4c45c314b6e9d73a82dec6d737519c674bb139c2ef70511aa0 SHA512 e4805dbddf7cd0f0faf412557d408509650c1ccf703bc450f10a3f727c690dbfaa1235aa81939a0e4b7ac6190f88c15ea1fcc562b343d4b4c7550f967aeb15db
+DIST grep-3.4.tar.xz 1555820 BLAKE2B 4e1924d6d5eb66faca93b405cce9784d726a476f26a384c3b44375cb09f817008aeedaa701a30b6c1f21c030902d603a80ec80105b2d5d76eadf09b910d573a7 SHA512 0f1506bd19971fbdcb47a111277ca63e8ad045456f096980852fd0a61c860f29f4b369bbaaa5cbce4b0a81718e3e3274d9a078b491f2109baa9a02ce600ee206
diff --git a/sys-apps/grep/grep-3.4.ebuild b/sys-apps/grep/grep-3.4.ebuild
new file mode 100644
index 000000000000..db80d522f833
--- /dev/null
+++ b/sys-apps/grep/grep-3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="https://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls pcre static"
+
+LIB_DEPEND="pcre? ( >=dev-libs/libpcre-7.8-r1[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ sed -i \
+ -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
+ -e "s:@grep@:${EPREFIX}/bin/grep:" \
+ src/egrep.sh || die #523898
+
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ # don't link against libsigsegv even when available
+ export ac_cv_libsigsegv=no
+ # Always use pkg-config to get lib info for pcre.
+ export ac_cv_search_pcre_compile=$(
+ usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
+ )
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ $(use_enable nls)
+ $(use_enable pcre perl-regexp)
+ )
+ econf "${myeconfargs[@]}"
+}