summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-04-20 16:22:29 +0100
committerMarek Szuba <marecki@gentoo.org>2022-04-20 16:25:04 +0100
commitf7247509e0c0e26f246547e3079ad6d2778593f8 (patch)
tree6b5dc5c301a9a216f50fcab3841a749315dc8bee /sys-auth/solo1
parentsys-auth/solo-python: drop 0.0.31 (diff)
downloadgentoo-f7247509e0c0e26f246547e3079ad6d2778593f8.tar.gz
gentoo-f7247509e0c0e26f246547e3079ad6d2778593f8.tar.bz2
gentoo-f7247509e0c0e26f246547e3079ad6d2778593f8.zip
sys-auth/solo-python: rename to sys-auth/solo1
Name changed upstream starting with version 0.1.0 in order to emphasise this software only works with Solo 1. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth/solo1')
-rw-r--r--sys-auth/solo1/Manifest1
-rw-r--r--sys-auth/solo1/metadata.xml19
-rw-r--r--sys-auth/solo1/solo1-0.1.1.ebuild39
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-auth/solo1/Manifest b/sys-auth/solo1/Manifest
new file mode 100644
index 000000000000..840c5853de82
--- /dev/null
+++ b/sys-auth/solo1/Manifest
@@ -0,0 +1 @@
+DIST solo1-0.1.1.tar.gz 39300 BLAKE2B 3d486d7d515acf03131ef640e38f804f10b4601db37d2b668ea50a715e5b0b38e95d16f3dec41a282bfaacf743a531ef6b56f9b688bdbb7d7f8acc56bdd1d77c SHA512 7e345059205f8753d7d89a22091316f5a529e5afedd82f7a03acbe494035479ef28731cc2b91e8d46058ce638a0e420db8c5f57fcedfcc39b6d07de5eda86f93
diff --git a/sys-auth/solo1/metadata.xml b/sys-auth/solo1/metadata.xml
new file mode 100644
index 000000000000..d85a5fb1d267
--- /dev/null
+++ b/sys-auth/solo1/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The command-line tool 'solo1' provided by this package can be used to reset
+ a SoloKeys Solo 1, set/change the PIN, generate credentials, interact
+ with the on-board TRNG, update the firmware, and more. See the output
+ of 'solo1 key --help' for more information.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">solokeys/solo1-cli</remote-id>
+ <remote-id type="pypi">solo1</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/solo1/solo1-0.1.1.ebuild b/sys-auth/solo1/solo1-0.1.1.ebuild
new file mode 100644
index 000000000000..d2d01f96ae74
--- /dev/null
+++ b/sys-auth/solo1/solo1-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and Python library for SoloKeys Solo 1"
+HOMEPAGE="https://github.com/solokeys/solo1-cli"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~riscv"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test ${ver} -lt 0.1.1; then
+ ewarn "Note that since version 0.1.1 the CLI executable is called '${PN}' rather than 'solo'"
+ ewarn "The old name can still be used for now but is deprecated"
+ break
+ fi
+ done
+ fi
+}