summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-07-08 09:55:44 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-07-09 15:52:13 +0100
commit4edae64ba784128becf6c83316b409a2168881c7 (patch)
tree4735a2ebebf1d22994b0d1e91887da3998ea286e /sys-auth
parentapp-portage/gpyutils: Enable py3.13 (diff)
downloadgentoo-4edae64ba784128becf6c83316b409a2168881c7.tar.gz
gentoo-4edae64ba784128becf6c83316b409a2168881c7.tar.bz2
gentoo-4edae64ba784128becf6c83316b409a2168881c7.zip
sys-auth/microsoft-identity-broker: Add version 2.0.1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/microsoft-identity-broker/Manifest1
-rw-r--r--sys-auth/microsoft-identity-broker/microsoft-identity-broker-2.0.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/microsoft-identity-broker/Manifest b/sys-auth/microsoft-identity-broker/Manifest
index c712e5f50e48..fc797897d322 100644
--- a/sys-auth/microsoft-identity-broker/Manifest
+++ b/sys-auth/microsoft-identity-broker/Manifest
@@ -1 +1,2 @@
DIST microsoft-identity-broker_2.0.0_amd64.deb 83941724 BLAKE2B 6e7c347cd466b4fb77841c4c19cf368538adf17a1b197fcf5a8ca6555f3660f8d6684d6bcb400441f9cc06f0765b26cf379d29a16f15d2f90da445d80f89ae89 SHA512 60535f64f867fcd748f550b4dd5a9bb29d527b3632dc7d44a72041ad36ccb691e762417bdc0230ead6ad8c0ab3099f0a343a5be7ab4c982fd3c27753712ac462
+DIST microsoft-identity-broker_2.0.1_amd64.deb 84379396 BLAKE2B 1e535ca26ba3736ac284ca1602b1c1ae9acd1d69f66ff17ab76477b7fa3dd5d6125a2ac6c9b651ca26d90592716d75de6aadb7ffa52f95d16930645224a9eb57 SHA512 88d389fbddbbb73c3b8ce7b943232069f23c36d74034dce070a301a5ce919934f0257cd5b5c70de382d9d5b08cd554ff9717d14de484e38d9a0eba68c7200cb6
diff --git a/sys-auth/microsoft-identity-broker/microsoft-identity-broker-2.0.1.ebuild b/sys-auth/microsoft-identity-broker/microsoft-identity-broker-2.0.1.ebuild
new file mode 100644
index 000000000000..f2f58f3974aa
--- /dev/null
+++ b/sys-auth/microsoft-identity-broker/microsoft-identity-broker-2.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 prefix systemd unpacker
+
+FAKE_OS="ubuntu-22.04"
+DESCRIPTION="Microsoft Authentication Broker to access a corporate environment"
+HOMEPAGE="https://learn.microsoft.com/mem/intune/"
+SRC_URI="https://packages.microsoft.com/ubuntu/22.04/prod/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_amd64.deb"
+S="${WORKDIR}"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ acct-user/microsoft-identity-broker
+ acct-group/microsoft-identity-broker
+ sys-apps/bubblewrap
+ sys-apps/dbus
+ virtual/jre:11
+"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_configure() {
+ sed -i -r "s:^Exec(Start)?=.*/([^/]+):Exec\1=${EPREFIX}/usr/bin/\2:" \
+ usr/lib/systemd/*/*.service usr/share/dbus-1/*/*.service || die
+}
+
+src_install() {
+ newbin $(prefixify_ro "${FILESDIR}"/wrapper) microsoft-identity-broker
+ dosym microsoft-identity-broker /usr/bin/microsoft-identity-device-broker
+
+ java-pkg_dojar opt/microsoft/identity-broker/lib/*.jar
+
+ java-pkg_dolauncher microsoft-identity-broker \
+ --main com.microsoft.identity.broker.service.IdentityBrokerService \
+ --java_args '${MICROSOFT_IDENTITY_BROKER_OPTS}' \
+ -into /usr/share/${PN}
+
+ java-pkg_dolauncher microsoft-identity-device-broker \
+ --main com.microsoft.identity.broker.service.DeviceBrokerService \
+ --java_args '${MICROSOFT_IDENTITY_DEVICE_BROKER_OPTS}' \
+ -into /usr/share/${PN}
+
+ insinto /etc/microsoft-identity-broker
+ newins "${FILESDIR}/lsb-release-${FAKE_OS}" lsb-release
+ newins "${FILESDIR}/os-release-${FAKE_OS}" os-release
+
+ insinto /usr/share
+ doins -r usr/share/dbus-1
+
+ systemd_dounit usr/lib/systemd/system/*
+ systemd_douserunit usr/lib/systemd/user/*
+}