summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-09-13 12:28:28 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 19:39:46 +0300
commitb9dd81488dbf97e5d26a0af54431c43c14703395 (patch)
treebb8bac241f5551e0b2395092417a620899a2e078 /sys-auth
parentapp-misc/klavaro: Stabilize 3.13-r1 amd64, #870124 (diff)
downloadgentoo-b9dd81488dbf97e5d26a0af54431c43c14703395.tar.gz
gentoo-b9dd81488dbf97e5d26a0af54431c43c14703395.tar.bz2
gentoo-b9dd81488dbf97e5d26a0af54431c43c14703395.zip
sys-auth/seatd: Disable setting USE=server by default
The desktop profile defaults to logind, this is probably where most users of libseat come from and while it is possible to use both seatd and (e)logind in tandem[1], it isn't a good default. [1] https://todo.sr.ht/~kennylevinsen/greetd/27#event-205371 Closes: https://bugs.gentoo.org/865411 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/seatd-0.7.0-r1.ebuild56
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild2
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-auth/seatd/seatd-0.7.0-r1.ebuild b/sys-auth/seatd/seatd-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..a3351b9b2463
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.7.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ server? ( acct-group/seat )
+"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
+}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index 0e20322a39a4..a3351b9b2463 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -16,7 +16,7 @@ else
fi
LICENSE="MIT"
SLOT="0/1"
-IUSE="builtin elogind +server systemd"
+IUSE="builtin elogind server systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="