summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-12-08 11:52:59 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-12-08 11:55:18 +0000
commite523130089add7743f122f1c622715710e9fb9e9 (patch)
treea871a5e96c8f3d8e5b9788b0de3ab4674330842e /sys-block/whdd/whdd-3.0.1.ebuild
parentprofiles: p.mask =net-libs/gnutls-3.7.0 (diff)
downloadgentoo-e523130089add7743f122f1c622715710e9fb9e9.tar.gz
gentoo-e523130089add7743f122f1c622715710e9fb9e9.tar.bz2
gentoo-e523130089add7743f122f1c622715710e9fb9e9.zip
sys-block/whdd: add new version 3.0.1
Bug: https://bugs.gentoo.org/741948 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'sys-block/whdd/whdd-3.0.1.ebuild')
-rw-r--r--sys-block/whdd/whdd-3.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-3.0.1.ebuild b/sys-block/whdd/whdd-3.0.1.ebuild
new file mode 100644
index 000000000000..e3e2b0a37fc6
--- /dev/null
+++ b/sys-block/whdd/whdd-3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog:=
+ sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}