summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2024-06-04 20:04:57 +0300
committerMatthew Thode <prometheanfire@gentoo.org>2024-06-17 15:10:04 -0500
commit5961006a720e03ca59f016da37bab5faac2a4fa1 (patch)
treeea850aa89da08c3f1fa84fd46cc055500149792d /sys-block
parentwww-apps/klaus: drop 3.0.0 (diff)
downloadgentoo-5961006a720e03ca59f016da37bab5faac2a4fa1.tar.gz
gentoo-5961006a720e03ca59f016da37bab5faac2a4fa1.tar.bz2
gentoo-5961006a720e03ca59f016da37bab5faac2a4fa1.zip
sys-block/tgt: add 1.0.92
Bug: https://bugs.gentoo.org/713490 Bug: https://bugs.gentoo.org/934448 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.92.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index aa413c25af67..1b8c248e227a 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1 +1,2 @@
DIST tgt-1.0.91.tar.gz 305813 BLAKE2B 8ab714ff6ce29ead7800a2538241ed93e3c363881c0d37009bf7074063ff88daa25969cb5ebcac2ac55ec475cd02756656c82bfaa855da88569f0b577034a8c0 SHA512 ea3a2d82c2533267a58b52d8db7cd8576447f1713ce5431955d2871272976b0e1c155c27c28e0bbf29b75b3e3a9fcf608e1fc1ce9ebeb558ae0219b0be2b5ad5
+DIST tgt-1.0.92.tar.gz 305797 BLAKE2B 144773460e5ab4241e9cf7e35f4b84b347da8a48dfbb2dfba4b0c02f7d346746a80f1f3c65cdbb0fa1c1dc25a19b0cbd951e6b9c38a9022f2136ffc95b67d00d SHA512 a865a61bae3c4503ad4a67192fc7d0f16f0dbf767d067f2a65ddc24f674ec33413a130b4861b7ab33324243489e45259644f84b7f2d8162005d23f0eb2476bd2
diff --git a/sys-block/tgt/tgt-1.0.92.ebuild b/sys-block/tgt/tgt-1.0.92.ebuild
new file mode 100644
index 000000000000..5488b8178802
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.92.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="https://github.com/fujita/tgt"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="infiniband rbd selinux"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils
+ selinux? ( sec-policy/selinux-tgtd )
+"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd-new tgtd
+ newconfd "${FILESDIR}"/tgtd.confd-new tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}