summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-04-10 08:59:26 -0400
committerMike Gilbert <floppym@gentoo.org>2018-04-10 08:59:26 -0400
commitb101f179c8032cfefd86a315f72920e98b6457b2 (patch)
tree3d25953b5670c8d9ebea8e01f84141121bd1eaa9 /sys-boot/efibootmgr/efibootmgr-16.ebuild
parentsys-libs/efivar: bump to 35 (diff)
downloadgentoo-b101f179c8032cfefd86a315f72920e98b6457b2.tar.gz
gentoo-b101f179c8032cfefd86a315f72920e98b6457b2.tar.bz2
gentoo-b101f179c8032cfefd86a315f72920e98b6457b2.zip
sys-boot/efibootmgr: bump to 16
Package-Manager: Portage-2.3.24, Repoman-2.3.6_p81
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-16.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-16.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-16.ebuild b/sys-boot/efibootmgr/efibootmgr-16.ebuild
new file mode 100644
index 000000000000..fc0c1a239f84
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
+SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ >=sys-libs/efivar-25:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-Werror //' Make.defaults || die
+}
+
+src_configure() {
+ tc-export CC
+ export EFIDIR="Gentoo"
+}