summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2019-10-18 23:08:57 +0200
committerMike Gilbert <floppym@gentoo.org>2019-10-29 17:11:31 -0400
commited552f6d59ebb74594841e0c3d79be45bda1781e (patch)
tree11af4153ccc2945657a554b0503b61744621ad70 /sys-boot/grub
parentdev-java/javatoolkit-0.6.1: bump (diff)
downloadgentoo-ed552f6d59ebb74594841e0c3d79be45bda1781e.tar.gz
gentoo-ed552f6d59ebb74594841e0c3d79be45bda1781e.tar.bz2
gentoo-ed552f6d59ebb74594841e0c3d79be45bda1781e.zip
sys-boot/grub: add platform xen_pvh
Closes: https://bugs.gentoo.org/697978 Closes: https://github.com/gentoo/gentoo/pull/13334 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/grub-2.04-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-2.04-r1.ebuild b/sys-boot/grub/grub-2.04-r1.ebuild
index 81bd769728c9..7135f70c7f98 100644
--- a/sys-boot/grub/grub-2.04-r1.ebuild
+++ b/sys-boot/grub/grub-2.04-r1.ebuild
@@ -55,7 +55,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -105,6 +105,7 @@ DEPEND="
ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
"
RDEPEND="${DEPEND}
kernel_linux? (
@@ -177,6 +178,7 @@ grub_configure() {
case ${MULTIBUILD_VARIANT} in
efi*) platform=efi ;;
+ xen-pvh) platform=xen_pvh ;;
xen*) platform=xen ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 07f21fac6705..6b165af82481 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -54,7 +54,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -104,6 +104,7 @@ DEPEND="
ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
"
RDEPEND="${DEPEND}
kernel_linux? (
@@ -176,6 +177,7 @@ grub_configure() {
case ${MULTIBUILD_VARIANT} in
efi*) platform=efi ;;
+ xen-pvh) platform=xen_pvh ;;
xen*) platform=xen ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;