summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-08-02 23:40:51 +0800
committerJason Zaman <perfinion@gentoo.org>2017-08-02 23:40:51 +0800
commit05a31c5a80c906a0b8e06436017a4588172f29e3 (patch)
treec9653405b288b80bb04a1d04b8efc95510d49967 /sys-boot/tboot
parentsys-boot/tboot: fix grub scripts to find initrd (diff)
downloadgentoo-05a31c5a80c906a0b8e06436017a4588172f29e3.tar.gz
gentoo-05a31c5a80c906a0b8e06436017a4588172f29e3.tar.bz2
gentoo-05a31c5a80c906a0b8e06436017a4588172f29e3.zip
sys-boot/tboot: drop old
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-boot/tboot')
-rw-r--r--sys-boot/tboot/Manifest2
-rw-r--r--sys-boot/tboot/tboot-1.9.4-r1.ebuild70
-rw-r--r--sys-boot/tboot/tboot-1.9.4_p20161101.ebuild70
3 files changed, 0 insertions, 142 deletions
diff --git a/sys-boot/tboot/Manifest b/sys-boot/tboot/Manifest
index 6d9c0458aa30..5e633ae5929f 100644
--- a/sys-boot/tboot/Manifest
+++ b/sys-boot/tboot/Manifest
@@ -1,3 +1 @@
-DIST tboot-1.9.4.tar.gz 2107175 SHA256 7167e5615def4ac0f25b2f9139b3d361a0a20d91386d80b1d865107b3f552f39 SHA512 93db95be54a1286dffe87cf6f5d1e31ac0c4a452b11a11789fec66255c847a9e14251579de0f6ba4c5c122423b45e83751a8287d37e27ea3acba608774d7ac0b WHIRLPOOL 2bf9220317dc5bbc927fb10d07a1d7f5cef2d5351fbf81e45f276b5f317785c1cfc1f1e4b78ac426bceb66641339d7179bff8fbbb867b67aa215544193a5baa1
-DIST tboot-1.9.4_p20161101.tar.gz 578097 SHA256 d6a399488fde1d0993a65bcb283cec218c7c8572972d2fdda8422fc2a1b5513f SHA512 6a38148d7be4faf8ec86f2f8e3c342321b7d8d4920a631b0e1b74bd27578039f4ae20faffae877ed8db5dd14500c059a3efd3eed24f22099820e87a67d3ecc17 WHIRLPOOL 316e3ac4965108a63ebf6075b50fb24b5c0a0c1527cb43309b95c64e60a0b6e5b3287e4b19faa8405ab10cf268b975cfd93d6348253a2d3fa07e78f38ef1eac8
DIST tboot-1.9.5.tar.gz 685460 SHA256 c7032e367ac0129493c9bb1fcd1437f400ff5533c970119ddce281ff4d58a13f SHA512 d806b692d3d57d0aaf4095ef514a2859b2b054ec695cb5589b3a6133eec7f7a9a0e76544e4b557df02add5ed67c3c15fb3ee5f17d6438252b659d6e5c7d17fe9 WHIRLPOOL 04843854b1a646d6126079a3b46bacf0c8191d5b5c322f8bc04ea39c0d5470bba2f7f2499761d42aa258552c1dfbeb626275e7473628b21719a6fe59bc05029c
diff --git a/sys-boot/tboot/tboot-1.9.4-r1.ebuild b/sys-boot/tboot/tboot-1.9.4-r1.ebuild
deleted file mode 100644
index 55a71d36d303..000000000000
--- a/sys-boot/tboot/tboot-1.9.4-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic mount-boot
-
-DESCRIPTION="Performs a measured and verified boot using Intel Trusted Execution Technology"
-HOMEPAGE="https://sourceforge.net/projects/tboot/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 -*"
-IUSE="custom-cflags selinux"
-
-# requires patching the kernel src
-RESTRICT="test"
-
-DEPEND="app-crypt/trousers
-app-crypt/tpm-tools
-dev-libs/openssl:0=[-bindist]"
-
-RDEPEND="${DEPEND}
-sys-boot/grub:2
-selinux? ( sec-policy/selinux-tboot )"
-
-DOCS=(README COPYING CHANGELOG)
-
-src_prepare() {
- sed -i 's/ -Werror//g' Config.mk || die
- sed -i 's/^INSTALL_STRIP = -s$//' Config.mk || die # QA Errors
-
- default
-}
-
-src_compile() {
- use custom-cflags && export TBOOT_CFLAGS=${CFLAGS} || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
-
- if use amd64; then
- MAKEARGS="TARGET_ARCH=x86_64"
- else
- MAKEARGS="TARGET_ARCH=i686"
- fi
-
- default
-}
-
-src_install() {
- emake DISTDIR="${D}" install
-
- dodoc "${DOCS[@]}"
- dodoc docs/*.txt lcptools/*.{txt,pdf} || die "docs failed"
-
- cd "${D}"
- mkdir -p usr/lib/tboot/ || die
- mv boot usr/lib/tboot/ || die
-}
-
-pkg_postinst() {
- mount-boot_mount_boot_partition
-
- cp ${ROOT%/}/usr/lib/tboot/boot/* ${ROOT%/}/boot/
-
- mount-boot_pkg_postinst
-
- ewarn "Please remember to download the SINIT AC Module relevant"
- ewarn "for your platform from:"
- ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"
-}
diff --git a/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild b/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild
deleted file mode 100644
index 51097ea32a49..000000000000
--- a/sys-boot/tboot/tboot-1.9.4_p20161101.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic mount-boot
-
-DESCRIPTION="Performs a measured and verified boot using Intel Trusted Execution Technology"
-HOMEPAGE="https://sourceforge.net/projects/tboot/"
-SRC_URI="http://dev.gentoo.org/~perfinion/distfiles/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 -*"
-IUSE="custom-cflags selinux"
-
-# requires patching the kernel src
-RESTRICT="test"
-
-DEPEND="app-crypt/trousers
-app-crypt/tpm-tools
-dev-libs/openssl:0=[-bindist]"
-
-RDEPEND="${DEPEND}
-sys-boot/grub:2
-selinux? ( sec-policy/selinux-tboot )"
-
-DOCS=(README COPYING CHANGELOG)
-
-src_prepare() {
- sed -i 's/ -Werror//g' Config.mk || die
- sed -i 's/^INSTALL_STRIP = -s$//' Config.mk || die # QA Errors
-
- default
-}
-
-src_compile() {
- use custom-cflags && export TBOOT_CFLAGS=${CFLAGS} || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
-
- if use amd64; then
- MAKEARGS="TARGET_ARCH=x86_64"
- else
- MAKEARGS="TARGET_ARCH=i686"
- fi
-
- default
-}
-
-src_install() {
- emake DISTDIR="${D}" install
-
- dodoc "${DOCS[@]}"
- dodoc docs/*.txt lcptools/*.{txt,pdf} || die "docs failed"
-
- cd "${D}"
- mkdir -p usr/lib/tboot/ || die
- mv boot usr/lib/tboot/ || die
-}
-
-pkg_postinst() {
- mount-boot_mount_boot_partition
-
- cp ${ROOT%/}/usr/lib/tboot/boot/* ${ROOT%/}/boot/
-
- mount-boot_pkg_postinst
-
- ewarn "Please remember to download the SINIT AC Module relevant"
- ewarn "for your platform from:"
- ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"
-}