summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2021-02-08 10:25:06 +0100
committerAlexys Jacob <ultrabug@gentoo.org>2021-02-08 10:25:40 +0100
commit032396b10b060a8f70ccef0db1ded63b6321bee5 (patch)
treeeae0b0b684ceb05660c9f62c28089d56d5850d9f /sys-cluster/crmsh/crmsh-4.2.1.ebuild
parentx11-drivers/nvidia-drivers: Accidentally deleted pkg_postrm (diff)
downloadgentoo-032396b10b060a8f70ccef0db1ded63b6321bee5.tar.gz
gentoo-032396b10b060a8f70ccef0db1ded63b6321bee5.tar.bz2
gentoo-032396b10b060a8f70ccef0db1ded63b6321bee5.zip
sys-cluster/crmsh: drop old, bump 4.2.1 fix #758401
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'sys-cluster/crmsh/crmsh-4.2.1.ebuild')
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.2.1.ebuild b/sys-cluster/crmsh/crmsh-4.2.1.ebuild
new file mode 100644
index 000000000000..312f01a1ed1b
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+AUTOTOOLS_AUTORECONF=true
+KEYWORDS=""
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit eutils python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_configure() {
+ ./autogen.sh || die
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}