summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-07 10:05:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-07 10:14:49 -0500
commitbee4dbb817e0832696204977d9bc6e5d68bc907b (patch)
treef12c6346ee5bc0f7158c156a940d864291425fff /sys-cluster/heat
parentsys-cluster/neutron: 16.2.0 bump (diff)
downloadgentoo-bee4dbb817e0832696204977d9bc6e5d68bc907b.tar.gz
gentoo-bee4dbb817e0832696204977d9bc6e5d68bc907b.tar.bz2
gentoo-bee4dbb817e0832696204977d9bc6e5d68bc907b.zip
sys-cluster/heat: 14.1.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/heat')
-rw-r--r--sys-cluster/heat/Manifest2
-rw-r--r--sys-cluster/heat/heat-14.1.0.ebuild165
-rw-r--r--sys-cluster/heat/heat-2020.1.9999.ebuild4
3 files changed, 169 insertions, 2 deletions
diff --git a/sys-cluster/heat/Manifest b/sys-cluster/heat/Manifest
index 7414cabed28d..f3f11cd41b96 100644
--- a/sys-cluster/heat/Manifest
+++ b/sys-cluster/heat/Manifest
@@ -1,3 +1,5 @@
DIST heat.conf.sample-14.0.0 76935 BLAKE2B 7d664c9ec9a9efdcd851ed9f864cfa0d07dd68d3698243182f41d7df5f14711c14fb0e9390fb367ac3715f3b69dab09e4a6e0cb1c6a308470cdc9eba836726c3 SHA512 ccf53ac37ac5424c228ff430855fd5af65aa70df2ca3c21b04a64deec8a01a65be3d5b9367c512148e82f44eba327b31007b952d930820cb773219950d4398b0
+DIST heat.conf.sample-14.1.0 76935 BLAKE2B 7d664c9ec9a9efdcd851ed9f864cfa0d07dd68d3698243182f41d7df5f14711c14fb0e9390fb367ac3715f3b69dab09e4a6e0cb1c6a308470cdc9eba836726c3 SHA512 ccf53ac37ac5424c228ff430855fd5af65aa70df2ca3c21b04a64deec8a01a65be3d5b9367c512148e82f44eba327b31007b952d930820cb773219950d4398b0
DIST heat.conf.sample-2020.1.9999 76935 BLAKE2B 7d664c9ec9a9efdcd851ed9f864cfa0d07dd68d3698243182f41d7df5f14711c14fb0e9390fb367ac3715f3b69dab09e4a6e0cb1c6a308470cdc9eba836726c3 SHA512 ccf53ac37ac5424c228ff430855fd5af65aa70df2ca3c21b04a64deec8a01a65be3d5b9367c512148e82f44eba327b31007b952d930820cb773219950d4398b0
DIST openstack-heat-14.0.0.tar.gz 2393821 BLAKE2B 93d4728166496213447571afe9745d217431c1871ee415d413ff96e940c7fe0e9e7d97512cec8dc864564796ac15dd8c5f16e62ecabd6603939074ebba81612a SHA512 973818f33d24d057ce84c8826f50516566ae47386e9559ea2124d5c68f7cfbdf53390bcc7786e1cd29482c3f63ecfee2a10c01bb542fa59141f36cf52b0a5ec3
+DIST openstack-heat-14.1.0.tar.gz 2356647 BLAKE2B 0b4d009fcb631929bdc1e9a429e3370a546fb1763ab66439cd3791b1437417ef18da46f4bae8397bc5a661e09acbceb09d2f32dc06a190852f67989b900035ac SHA512 b74795ae10d29348b47c91d8de2166999ab51caef42521d9347565414ba1f2bbd2870c54af9d3877fe11e1388c900e64ed780a0e22a1270adea6cb1cc4971e0b
diff --git a/sys-cluster/heat/heat-14.1.0.ebuild b/sys-cluster/heat/heat-14.1.0.ebuild
new file mode 100644
index 000000000000..8ad0dab1631c
--- /dev/null
+++ b/sys-cluster/heat/heat-14.1.0.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="A CloudFormation-compatible openstack-native cloud orchestration engine."
+HOMEPAGE="https://launchpad.net/heat"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.ussuri -> heat.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/heat.git"
+ EGIT_BRANCH="stable/ussuri"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.ussuri -> heat.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/openstack-${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/openstack-${P}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+mysql +memcached postgres sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}
+ app-admin/sudo"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/croniter-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.20.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/keystonemiddleware-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.4.1[${PYTHON_USEDEP}]
+ !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/neutron-lib-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-cache-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.27.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-reports-1.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.37.0[${PYTHON_USEDEP}]
+ >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/aodhclient-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.5.2[${PYTHON_USEDEP}]
+ >=dev-python/python-blazarclient-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-heatclient-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-ironicclient-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-magnumclient-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-manilaclient-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/python-mistralclient-3.1.0[${PYTHON_USEDEP}]
+ !~dev-python/python-mistralclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-monascaclient-1.12.0[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-6.14.0[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-octaviaclient-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/python-saharaclient-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-troveclient-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-vitrageclient-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-zaqarclient-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-zunclient-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/tenacity-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ sqlite? (
+ >=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ >=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/yaql-1.1.3[${PYTHON_USEDEP}]
+ acct-user/heat
+ acct-group/heat"
+
+PATCHES=(
+)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ diropts -m0750 -o heat -g heat
+ keepdir /etc/heat
+ dodir /etc/heat/environment.d
+ dodir /etc/heat/templates
+
+ for svc in api api-cfn engine; do
+ newinitd "${FILESDIR}/heat.initd" heat-${svc}
+ done
+
+ insinto /etc/heat
+ insopts -m0640 -o heat -g heat
+ newins "${DISTDIR}/heat.conf.sample-${PV}" "heat.conf.sample"
+ doins "etc/heat/api-paste.ini"
+ insinto /etc/heat/templates
+ doins "etc/heat/templates/"*
+ insinto /etc/heat/environment.d
+ doins "etc/heat/environment.d/default.yaml"
+
+ dodir /var/log/heat
+ fowners heat:heat /var/log/heat
+ rm -r "${ED}"/usr/etc
+}
diff --git a/sys-cluster/heat/heat-2020.1.9999.ebuild b/sys-cluster/heat/heat-2020.1.9999.ebuild
index 16a42a5729f3..8ad0dab1631c 100644
--- a/sys-cluster/heat/heat-2020.1.9999.ebuild
+++ b/sys-cluster/heat/heat-2020.1.9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 eutils linux-info
@@ -28,8 +29,7 @@ REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
+DEPEND="${CDEPEND}
app-admin/sudo"
RDEPEND="