summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-20 15:00:48 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-20 15:00:48 -0600
commit5c5bcab17b925a1b5e8850a1165c7b483656ee5c (patch)
treebf0ddf2ab26115490fe0da8464ff8bf998e382d6 /sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild
parentsys-cluster/kubelet: add 1.26.1 (diff)
downloadgentoo-5c5bcab17b925a1b5e8850a1165c7b483656ee5c.tar.gz
gentoo-5c5bcab17b925a1b5e8850a1165c7b483656ee5c.tar.bz2
gentoo-5c5bcab17b925a1b5e8850a1165c7b483656ee5c.zip
sys-cluster/kube-proxy: add 1.26.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild
new file mode 100644
index 000000000000..c2bf8bb7da7f
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.26.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="net-firewall/conntrack-tools"
+BDEPEND=">=dev-lang/go-1.19"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}