summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-05-24 10:33:44 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-05-24 10:35:10 -0400
commitc4fc03c06cfa8a1c3f4b22fee2a3688ea48046be (patch)
treeb2257bc5516e16ac12114ab7446940c9b887ce8e /sys-cluster/torque/files
parentRevert "mail-client/thunderbird: stabilize 52.1.1 for amd64" (diff)
downloadgentoo-c4fc03c06cfa8a1c3f4b22fee2a3688ea48046be.tar.gz
gentoo-c4fc03c06cfa8a1c3f4b22fee2a3688ea48046be.tar.bz2
gentoo-c4fc03c06cfa8a1c3f4b22fee2a3688ea48046be.zip
sys-cluster/torque: fix CFLAGS munging on version bump to 4.2.10
This commit also bumps to EAPI6 and adjusts some other minor issues (REPLACING_VERSIONS checks, etc). Bug: http://bugs.gentoo.org/619436 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-cluster/torque/files')
-rw-r--r--sys-cluster/torque/files/torque-4.2-dont-mess-with-cflags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/torque/files/torque-4.2-dont-mess-with-cflags.patch b/sys-cluster/torque/files/torque-4.2-dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..aec54aff030f
--- /dev/null
+++ b/sys-cluster/torque/files/torque-4.2-dont-mess-with-cflags.patch
@@ -0,0 +1,27 @@
+--- a/configure.ac 2014-09-10 21:06:26.000000000 -0400
++++ b/configure.ac 2017-05-23 10:43:59.051759539 -0400
+@@ -703,24 +703,6 @@
+ AC_HELP_STRING([--with-debug], [compile with debugging symbols]),
+ DEBUG_SYMBOLS=$withval, DEBUG_SYMBOLS="yes")
+ AC_MSG_RESULT([DEBUG_SYMBOLS=$DEBUG_SYMBOLS])
+-dnl remove -O* and add -g
+-if test "$DEBUG_SYMBOLS" = 'yes'; then
+- AC_MSG_RESULT([before tweak CFLAGS=$CFLAGS])
+- CFLAGS=`echo $CFLAGS | sed 's/ \?-O[[^ ]]*//g'`
+- AC_MSG_RESULT([mid tweak CFLAGS=$CFLAGS])
+- case $CFLAGS in
+- *-g*)
+- ;;
+- *)
+- if test "$CFLAGS" = ''; then
+- CFLAGS="-g"
+- else
+- CFLAGS="-g $CFLAGS"
+- fi
+- ;;
+- esac
+- AC_MSG_RESULT([after tweak CFLAGS=$CFLAGS])
+-fi
+
+ dnl if using gcc, we can be very strict
+ AC_ARG_ENABLE(gcc_warnings, [