summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-12-19 19:44:15 +0100
committerNicolas Bock <nicolasbock@gentoo.org>2020-12-21 10:49:00 -0700
commitb82d6dd985ee8df23cf99769cf65a22df7886a0f (patch)
tree95a2353cecc0c405f5d90de9bfe4877734de6ba3 /sys-cluster
parentapp-emulation/xen-tools: x86 stable (bug #760144) (diff)
downloadgentoo-b82d6dd985ee8df23cf99769cf65a22df7886a0f.tar.gz
gentoo-b82d6dd985ee8df23cf99769cf65a22df7886a0f.tar.bz2
gentoo-b82d6dd985ee8df23cf99769cf65a22df7886a0f.zip
sys-cluster/charliecloud: Bump to version 0.21.
This adds a new local USE flag ch-image, following upstream's rename of ch-grow. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.21.ebuild80
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild8
-rw-r--r--sys-cluster/charliecloud/metadata.xml1
4 files changed, 86 insertions, 4 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index d85b2af17226..4ee45c25d3d3 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,2 +1,3 @@
DIST charliecloud-0.19.tar.gz 370553 BLAKE2B a87fc00a88528dfaf5a0a666ff92b98ee4bc7d37c5eaaa7c5029e4269b497d280e1e84757bf882f94480b618ac2430b0cc0550406317e8247155e1b380d30c8b SHA512 e2a000155ac2cc5bd40e1f2a7c2d873e4860bd5ef28a362ce5a04a1f4152b2ad1124055755c288e6ae5d40067661dfacbb77a528e3c071aa189765e0d29addb5
DIST charliecloud-0.20.tar.gz 372770 BLAKE2B a5e6ad3fc93aa7219ec8d35ae112fc7320befc909d2cc805f5d67a356840112c245581c18d790a4fc755e70240e6444059cab8b9531eaedb3e3b941cf756aa55 SHA512 e3269bbf667462214ba88f8fc4651396c9621cd315a798113b66e8be0d4367ce1c18b8b956f325bd07049d644b46fd6837c5b712ced4bdf20a42bcc9aaafd8b7
+DIST charliecloud-0.21.tar.gz 386637 BLAKE2B a5b115a9d741a2c83596a302e7dd3d0d6096eb11f3e38925009b05f5a16f2d6fa4ff1c0023789feae1d359c94e4970dcc62d597437c6f7143f8152603b0e9a88 SHA512 89351e4dc039cd724c7503a4855f0980128d28aa4e2e98c5fd8cc5060e2c853e65280b830526691c8d4c7d85168658d578236893075637e3a38c6eb1df4e8dfe
diff --git a/sys-cluster/charliecloud/charliecloud-0.21.ebuild b/sys-cluster/charliecloud/charliecloud-0.21.ebuild
new file mode 100644
index 000000000000..9d82ccea8d02
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.21.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools optfeature python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="ch-image doc"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="
+ ch-image? (
+ $(python_gen_cond_dep '
+ dev-python/lark-parser[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_MULTI_USEDEP}]
+ ')
+ net-misc/rsync
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=()
+ econf_args+=(
+ $(use_enable doc html)
+ $(use_enable ch-image)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python=${PYTHON}
+ # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
+ --enable-buggy-build
+ )
+ econf "${econf_args[@]}"
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative "
+ elog "to the internal ch-image. The following packages "
+ elog "can be installed to get the corresponding support "
+ elog "and related functionality."
+
+ optfeature "Building with Buildah" app-emulation/buildah
+ optfeature "Building with Docker" app-emulation/docker
+ optfeature "Progress bars during long operations" sys-apps/pv
+ optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
+ optfeature "Mount and umount squashfs images" sys-fs/squashfuse
+}
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index af2a098d694e..9d82ccea8d02 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://hpc.github.io/charliecloud/"
SLOT="0"
LICENSE="Apache-2.0"
-IUSE="ch-grow doc"
+IUSE="ch-image doc"
# Extensive test suite exists, but downloads container images
# directly and via Docker and installs packages inside using apt/yum.
@@ -32,7 +32,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}"
DEPEND="
- ch-grow? (
+ ch-image? (
$(python_gen_cond_dep '
dev-python/lark-parser[${PYTHON_MULTI_USEDEP}]
dev-python/requests[${PYTHON_MULTI_USEDEP}]
@@ -55,7 +55,7 @@ src_configure() {
local econf_args=()
econf_args+=(
$(use_enable doc html)
- $(use_enable ch-grow)
+ $(use_enable ch-image)
# Libdir is used as a libexec-style destination.
--libdir="${EPREFIX}"/usr/lib
# Attempts to call python-exec directly otherwise.
@@ -68,7 +68,7 @@ src_configure() {
pkg_postinst() {
elog "Various builders are supported, as alternative "
- elog "to the internal ch-grow. The following packages "
+ elog "to the internal ch-image. The following packages "
elog "can be installed to get the corresponding support "
elog "and related functionality."
diff --git a/sys-cluster/charliecloud/metadata.xml b/sys-cluster/charliecloud/metadata.xml
index 5abb0dbdbf54..c24a2db8e2ed 100644
--- a/sys-cluster/charliecloud/metadata.xml
+++ b/sys-cluster/charliecloud/metadata.xml
@@ -13,6 +13,7 @@
<remote-id type="github">hpc/charliecloud</remote-id>
</upstream>
<use>
+ <flag name='ch-image'>Build the internal builder ch-image (previously named ch-grow)</flag>
<flag name='ch-grow'>Build the internal builder ch-grow</flag>
<flag name='squashfs'>Use sys-fs/squashfs-tools for creating SquashFS images</flag>
<flag name='squashfuse'>Use sys-fs/squashfuse for the SquashFS workflow</flag>